[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Openshift V4 Broker does not see Node



Just noticed that mcollective server.cfg had wrong facts file:

update to 
/opt/rh/ruby193/root/etc/mcollective/facts.yaml

[root brokerdev ~]# oo-admin-ctl-district -c add-node -n small_district -a
Success for node 'nodesmall.example.com'!


{"_id"=>"53ca89a61827ae7970000001",
 "active_servers_size"=>1,
 "available_capacity"=>6000,
 "available_uids"=>"<6000 uids hidden>",
 "created_at"=>2014-07-19 15:07:18 UTC,
 "gear_size"=>"small",
 "max_capacity"=>6000,
 "max_uid"=>6999,
 "name"=>"small_district",
 "platform"=>"linux",
 "servers"=>
  [{"_id"=>"53ca8fd31827ae1c3f000001",
    "active"=>true,
    "name"=>"nodesmall.amakitu.com",
    "unresponsive"=>false}],
 "updated_at"=>2014-07-19 15:07:18 UTC,
 "uuid"=>"53ca89a61827ae7970000001"}


Thank you very much for helping to troubleshoot!

On 19 Jul 2014, at 18:33, Diego Castro <diego castro getupcloud com> wrote:

Try oo-accept-node and oo-accept-broker respectively , this error is new, looks like bad gem version. 

Send me also the openshift and openshift-deps yum repos config.

Diego Castro
The CloudFather
+55 (11) 987.411.183
gtalk: diego castro getupcloud com

This message and any attachment are solely for the intended
recipient and may contain confidential or privileged information
and it can not be forwarded or shared without permission.
Thank you!


2014-07-19 12:22 GMT-03:00 Andrei Colta <andrycolt007 gmail com>:
Dedicated node and broker.

Mcollective config from the Broker:
root brokerdev ~]# cat /opt/rh/ruby193/root/etc/mcollective/client.cfg 
main_collective = mcollective
collectives = mcollective
libdir = /opt/rh/ruby193/root/usr/libexec/mcollective
logfile = /var/log/openshift/broker/ruby193-mcollective-client.log
loglevel = debug

# Plugins
securityprovider = psk
plugin.psk = unset

connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = brokerdev.example.com
plugin.activemq.pool.1.port = 61613
plugin.activemq.pool.1.user = mcollective
plugin.activemq.pool.1.password = mcollective

plugin.activemq.stomp_1_0_fallback = 0
plugin.activemq.heartbeat_interval = 30
plugin.activemq.max_hbread_fails = 2
plugin.activemq.max_hbrlck_fails = 2

Mcollective config form Node:

[root nodesmall openshift]# cat /opt/rh/ruby193/root/etc/mcollective/client.cfg 
main_collective = mcollective
collectives = mcollective
libdir = /opt/rh/ruby193/root/usr/libexec/mcollective
logfile = /var/log/openshift/node/ruby193-mcollective.log
loglevel = debug
daemonize = 1
direct_addressing = 0
registerinterval = 30

# Plugins
securityprovider = psk
plugin.psk = unset

connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = brokerdev.example.com
plugin.activemq.pool.1.port = 61613
plugin.activemq.pool.1.user = mcollective
plugin.activemq.pool.1.password = mcollective

plugin.activemq.stomp_1_0_fallback = 0
plugin.activemq.heartbeat_interval = 30
plugin.activemq.max_hbread_fails = 2
plugin.activemq.max_hbrlck_fails = 2

# Facts
factsource = yaml
plugin.yaml = /opt/rh/ruby193/root/etc/mcollective/facts.yaml


[root nodesmall openshift]# cat /opt/rh/ruby193/root/etc/mcollective/server.cfg 
main_collective = mcollective
collectives = mcollective
libdir = /opt/rh/ruby193/root/usr/libexec/mcollective/
logfile = /var/log/mcollective.log
loglevel = info
daemonize = 1

# Plugins
securityprovider = psk
plugin.psk = unset

connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = brokerdev.example.com
plugin.activemq.pool.1.port = 61613
plugin.activemq.pool.1.user = mcollective
plugin.activemq.pool.1.password = mcollective

# Facts
factsource = yaml
plugin.yaml = /etc/mcollective/facts.yaml



On 19 Jul 2014, at 18:19, Diego Castro <diego castro getupcloud com> wrote:

Are you running all-in-one installation or is dedicated node and broker ?

Diego Castro
The CloudFather
+55 (11) 987.411.183
gtalk: diego castro getupcloud com

This message and any attachment are solely for the intended
recipient and may contain confidential or privileged information
and it can not be forwarded or shared without permission.
Thank you!


2014-07-19 12:12 GMT-03:00 Andrei Colta <andrycolt007 gmail com>:
Hello Diego,

Thanks for trying to help, this are the logs:

~]# oo-admin-ctl-district -c create -n small_district -p small
Successfully created district: 53ca89a61827ae7970000001

{"_id"=>"53ca89a61827ae7970000001",
 "uuid"=>"53ca89a61827ae7970000001",
 "available_uids"=>"<6000 uids hidden>",
 "name"=>"small_district",
 "platform"=>"linux",
 "gear_size"=>"small",
 "available_capacity"=>6000,
 "max_uid"=>6999,
 "max_capacity"=>6000,
 "active_servers_size"=>0,
 "updated_at"=>2014-07-19 15:07:18 UTC,
 "created_at"=>2014-07-19 15:07:18 UTC}

[root brokerdev ~]# oo-admin-ctl-district -c add-node -n small_district -i nodesmall.example.com
/usr/sbin/oo-admin-ctl-district:215:in `block in <main>': undefined method `casecmp' for nil:NilClass (NoMethodError)
from /usr/sbin/oo-admin-ctl-district:178:in `block in collate_errors'
from /usr/sbin/oo-admin-ctl-district:176:in `each'
from /usr/sbin/oo-admin-ctl-district:176:in `collate_errors'
from /usr/sbin/oo-admin-ctl-district:213:in `<main>'
[root brokerdev ~]# oo-mco ping
nodesmall.example.com                    time=86.02 ms
^C

---- ping statistics ----
1 replies max: 86.02 min: 86.02 avg: 86.02 

INFO: checking node profiles via MCollective
FAIL: test_node_profiles_districts_from_broker
          No node hosts found. Please install some,
          or ensure the existing ones respond to 'oo-mco ping'.
          OpenShift cannot host gears without at least one node host responding.



INFO: running oo-accept-systems -w 2
FAIL: run_script
oo-accept-systems -w 2 had errors:
--BEGIN OUTPUT--
FAIL: No node hosts responded. Run 'oo-mco ping' and troubleshoot if this is unexpected.
1 ERRORS

On 19 Jul 2014, at 16:17, Diego Castro <diego castro getupcloud com> wrote:


From Node:

]# grep profile /etc/openshift/resource_limits.conf 
node_profile=small

]# grep profile /opt/rh/ruby193/root/etc/mcollective/facts.yaml 
node_profile: small



Hi Andrei, i could you share the whole output of oo-mco ping and the district add?

Diego Castro
The CloudFather
+55 (11) 987.411.183
gtalk: diego castro getupcloud com

This message and any attachment are solely for the intended
recipient and may contain confidential or privileged information
and it can not be forwarded or shared without permission.
Thank you!


2014-07-19 6:15 GMT-03:00 Andrei Colta <andrycolt007 gmail com>:
Hello,

I have installed Openshift V4, Centos 6.5. When I perform oo-mco ping i get the reply.
when trying to add district node i get no nodes available, node profile is right, what can be the issue?

Regards,
Andrei

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]