[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

OpenShift Enterprise 2.1 fresh install package dep failure



I'm trying to install OpenShift Enterprise 2.1 on physical bare-metal hosts using the same procedure that worked for me on ESX just last week. I am running into failures with missing repos, though I'm using the same subscription settings as before (RH Openshift Partner).

Running 'yum repolist' shows:

[root broker ~]# yum repolist
Loaded plugins: product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
rhel-6-server-ose-2.1-infra-rpms                                                                                            | 3.1 kB     00:00
rhel-6-server-ose-2.1-jbosseap-rpms                                                                                         | 3.1 kB     00:00
rhel-6-server-ose-2.1-node-rpms                                                                                             | 3.1 kB     00:00
rhel-6-server-ose-2.1-rhc-rpms                                                                                              | 3.1 kB     00:00
rhel-6-server-rpms                                                                                                          | 3.7 kB     00:00
repo id                                                     repo name                                                                        status
rhel-6-server-ose-2.1-infra-rpms                            Red Hat OpenShift Enterprise 2.1 Infrastructure (RPMs)                              138
rhel-6-server-ose-2.1-jbosseap-rpms                         Red Hat OpenShift Enterprise 2.1 JBoss EAP add-on (RPMs)                              3
rhel-6-server-ose-2.1-node-rpms                             Red Hat OpenShift Enterprise 2.1 Application Node (RPMs)                            318
rhel-6-server-ose-2.1-rhc-rpms                              Red Hat OpenShift Enterprise 2.1 Client Tools (RPMs)                                 14
rhel-6-server-rpms                                          Red Hat Enterprise Linux 6 Server (RPMs)                                         12,592
repolist: 13,065

Seems like I remember seeing 
I get errors during installation of the form (lots more than shown here):

--> Finished Dependency Resolution
Error: Package: ruby193-rubygem-json_pure-1.7.3-1.el6.noarch (rhel-6-server-ose-2.1-infra-rpms)
           Requires: ruby193-ruby(abi) = 1.9.1
Error: Package: ruby193-rubygem-regin-0.3.7-4.el6op.noarch (rhel-6-server-ose-2.1-infra-rpms)
           Requires: ruby193-rubygems
Error: Package: openshift-origin-broker-1.16.1.3-1.el6op.noarch (rhel-6-server-ose-2.1-infra-rpms)
           Requires: ruby193-rubygem-sprockets

Any idea why things are suddenly failing for me and what to do about it? I am a novice at yum/repository management...


After a bit more digging, it looks like I'm getting HTTP 502 Bad gateway during some RHSM traffic (from /var/log/rhsm/rhsm.log):

2014-06-03 15:09:24,984 [DEBUG]  @connection.py:441 - Making request: POST /subscription/consumers/d58744f8-8bea-4dac-9685-494a9d5ec33f/entitlements?pool=8a85f9814119250f0141195877140f6b
2014-06-03 15:09:25,486 [DEBUG]  @connection.py:460 - Response status: 502
2014-06-03 15:09:25,486 [ERROR]  @connection.py:489 - Response: 502
2014-06-03 15:09:25,486 [ERROR]  @connection.py:490 - JSON parsing error: No JSON object could be decoded
2014-06-03 15:09:25,487 [ERROR]  @managercli.py:151 - Unable to attach: Server error attempting a POST to /subscription/consumers/d58744f8-8bea-4dac-9685-494a9d5ec33f/entitlements?pool=8a85f9814119250f0141195877140f6b returned status 502
2014-06-03 15:09:25,487 [ERROR]  @managercli.py:152 - Server error attempting a POST to /subscription/consumers/d58744f8-8bea-4dac-9685-494a9d5ec33f/entitlements?pool=8a85f9814119250f0141195877140f6b returned status 502
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1409, in _do_command
    ents = self.cp.bindByEntitlementPool(consumer_uuid, pool, self.options.quantity)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 886, in bindByEntitlementPool
    return self.conn.request_post(method)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 544, in request_post
    return self._request("POST", method, params)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 469, in _request
    self.validateResponse(result, request_type, handler)
  File "/usr/lib64/python2.6/site-packages/rhsm/connection.py", line 517, in validateResponse
    handler=handler)
RemoteServerException: Server error attempting a POST to /subscription/consumers/d58744f8-8bea-4dac-9685-494a9d5ec33f/entitlements?pool=8a85f9814119250f0141195877140f6b returned status 502

Is there a problem with an RHSM server?

Randall Theobald
Common Engineering – Performance
Dell Software Group  |  Office of the CTO
randall_theobald dell com  |  RR1-C336



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]