[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: openshift-broker does't start



On Jun 8, 2014, at 10:40 AM, Marius Stanca <salut mariuss net> wrote:

> Hello community,
> 
> Does anyone know why openshift-broker  is not starting?
> 
> Starting openshift-broker: [Sun Jun 08 14:33:33 2014] [warn] module
> auth_basic_module is already loaded, skipping
> [Sun Jun 08 14:33:33 2014] [warn] module authz_user_module is already
> loaded, skipping
> httpd: Syntax error on line 255 of
> /var/www/openshift/broker/httpd/httpd.conf: Syntax error on line 4 of
> /var/www/openshift/broker/httpd/conf.d/openshift-origin-auth-remote-user.conf:
> Cannot load /var/www/openshift/broker/httpd/modules/mod_auth_kerb.so
> into server: /var/www/openshift/broker/httpd/modules/mod_auth_kerb.so:
> cannot open shared object file: No such file or directory
>                                                           [FAILED]
> 
> I cheeked the file config and everyting seems to be OK.
> 

Hi,

Are you using Kerberos for your implementation?  IPA, FreeIPA, etc..?

I ask because from what little I see in the above error, it’s trying to call that kerberos module — which is being reported as something that doesn’t exist.  

Are you using the plain old basic auth, and demo user for your test?  If so, you can just comment out "/var/www/openshift/broker/httpd/modules/mod_auth_kerb.so” in that config file.  

Optionally, you can also do a “yum -y install mod_auth_kerb” and try to cycle the services again.


> Best,
> 
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]