[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Oo-install all-in-one centos 6.5



HI.

I change my repo :

[root broker ~]# cat oo_install_configure_broker.open.local.pp
class { 'openshift_origin' :
  node_ip_addr => '192.168.0.100',
  bind_key => 'tvGZrdVXQT2nOoa61LmQsRDdO7W9+XqWvnVCOlG02X0R5qA8Ro/WmbYbetj7LO1aOVo62eewbL8g+XHSPNSTOA==',
  repos_base => 'https://mirror.openshift.com/pub/origin-server/release/3/rhel-6',
  broker_ip_addr => '192.168.0.100',
  node_hostname => 'broker.open.local',
  named_ip_addr => '192.168.0.100',
  install_method => 'yum',
  jenkins_repo_base => 'http://pkg.jenkins-ci.org/redhat',
  named_hostname => 'broker.open.local',
  activemq_hostname => 'broker.open.local',
  conf_node_external_eth_dev => 'eth0',
  domain => 'openshift.local',
  datastore_hostname => 'broker.open.local',
  roles => ['activemq','datastore','broker','named','node'],
  broker_hostname => 'broker.open.local',
}


[root broker ~]# scl enable ruby193 "puppet apply --verbose oo_install_configure_broker.open.local.pp"
Puppet::Parser::AST::Resource failed with error ArgumentError: Could not find declared class openshift_origin at /root/oo_install_configure_broker.open.local.pp:17 on node broker.lab.lan



2014-03-24 20:14 GMT+01:00 N. Harrison Ripps <hripps redhat com>:
Hey there--

On Mar 24, 2014, at 15:12, Luke Meyer <lmeyer redhat com> wrote:

> I hit this at some point, but can't remember the exact circumstance. I think it was an issue of puppet being the wrong version or something (unable to understand parameterized modules?). Are you using the latest puppet enterprise? My issue was on RHEL so I don't think it matters that it's CentOS.
>
> Regarding the config below, note that the repos_base is pointing to Fedora 19. That's definitely going to be a problem on CentOS.

Good catch Luke! Also --

>
> ----- Original Message -----
> From: "Kevin Tibi" <kevintibi hotmail com>
> To: "N. Harrison Ripps" <hripps redhat com>
> Cc: users lists openshift redhat com
> Sent: Saturday, March 22, 2014 11:05:43 AM
> Subject: Re: Oo-install all-in-one centos 6.5
>
>
>
> Hi,
>
>
> Yes i use this repo.
>
>
> I tried your solution :
>
>
>
> [root broker ~]# puppet apply -verbose oo_install_configure_broker.openshift.lab.lan.pp
> Could not parse for environment production: Syntax error at end of file at line 1 on node broker.openshift.lab.lan

In order for this to work, you need to wrap the command in the ruby193 SCL:

scl enable ruby193 "puppet apply --verbose <file>.pp"

>
>
> [root broker ~]# cat oo_install_configure_broker.openshift.lab.lan.pp
> class { 'openshift_origin' :
> broker_hostname => 'broker.openshift.lab.lan',
> node_hostname => 'broker.openshift.lab.lan',
> install_method => 'yum',
> node_ip_addr => '192.168.0.100',
> bind_key => 'b0okSptwh5ZId+VL8bANtJphZkcljSChyL+EZeTLpXbl/r0CFEHtaCjqBwSBVgDWfECrxjfuZ7yO+jeNw3KRNQ==',
> named_ip_addr => '192.168.0.100',
> named_hostname => 'broker.openshift.lab.lan',
> repos_base => ' https://mirror.openshift.com/pub/origin-server/release/3/fedora-19 ',
> jenkins_repo_base => ' http://pkg.jenkins-ci.org/redhat ',
> broker_ip_addr => '192.168.0.100',
> activemq_hostname => 'broker.openshift.lab.lan',
> conf_node_external_eth_dev => 'eth0',
> datastore_hostname => 'broker.openshift.lab.lan',
> domain => 'apps.lab.lan',
> roles => ['activemq','datastore','broker','named','node'],
> }
>
>
> [root broker ~]# hostname
> broker.openshift.lab.lan
>
>
>
>
>
> 2014-03-22 14:28 GMT+01:00 N. Harrison Ripps < hripps redhat com > :
>
>
>
>
> Hey Kevin--
>
>
> On Mar 22, 2014, at 8:44, Kevin Tibi < kevintibi hotmail com > wrote:
>
>
>
>
>
>
> Hi all,
>
> I am a new user OpenShift. I need help because I can not install with oo-install. I'm on centos6.5. I followed the official tutorial. after the script is completed without errors, I feel that nothing works. I do not have broker.conf file in /etc/OpenShift.
>
> http://localhost/console give nothing.
> A few things here:
>
>
> * did you use the RHEL repo for OpenShift RPMs?
>
>
>    *
>
> http://mirror.openshift.com/pub/origin-server/release/3/rhel-6
>
>
>
> What is the output if you run oo-accept-node and oo-accept-broker ?
>
>
> Another user on CentOS noted that puppet didn't seem to work. You can test that by:
>
>
> 1. Using oo-install's "generate a puppet config file" option to just make the config file
> 2. Manually running puppet with that config file:
>
>
> puppet apply --verbose /path/to/config/file.pp
>
>
>
>
>
>
> I'm lost. Thx for your help.
>
> Kevin Tibi
>
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.redhat.com/openshiftmm/listinfo/users
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users
>
>
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]