[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Error With OPenShift Origin V4 using oo-install



Got this issue fixed.

Thanks


On Wed, Nov 5, 2014 at 3:53 PM, Shabna M <shabsrh gmail com> wrote:
Hi All

I am trying OpenShift Origin Version 3 Install  with oo- install utility in aws ec2. but running into an issue with broker -

Installation Method  : oo-install (http://openshift.github.io/documentation/oo_install_users_guide.html )
Installation Setup : 1 Broker  (and other support service) +1 Node
OS: CentOS 6.4

What Works !!
----------------------
Installation went fine,  all service seems to be and running- 
oo-accept-node - works fine without errors.
oo-mco ping from broker host returns t he node ,so that also appears to be working.

What Fails !!
------------------

 oo-accept-broker is throwing the following exception :

/opt/rh/ruby193/root/usr/share/gems/gems/execjs-1.4.0/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a _javascript_ runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

        from /opt/rh/ruby193/root/usr/share/gems/gems/execjs-1.4.0/lib/execjs.rb:5:in `<module:ExecJS>'

        from /opt/rh/ruby193/root/usr/share/gems/gems/execjs-1.4.0/lib/execjs.rb:4:in `<top (required)>'

        from /opt/rh/ruby193/root/usr/share/gems/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `require'

        from /opt/rh/ruby193/root/usr/share/gems/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'

FAIL: Error while loading broker settings.

#####

 

      puts broker_conf.get('AUTH_SALT')

     puts console_conf.get('SESSION_SECRET')

      puts broker_conf.get('ENABLE_USER_ACTION_LOG')

      puts OpenShift::AuthService.instance_variable_get('@oo_auth_provider')

      puts OpenShift::ApplicationContainerProxy.instance_variable_get('@proxy_provider')

      puts OpenShift::DnsService.instance_variable_get('@oo_dns_provider')

      puts Rails.application.config.auth[:trusted_header]

      puts broker_conf.get('USER_ACTION_LOG_FILE')

      puts broker_conf.get('SESSION_SECRET')

#####

 

#####

1 ERRORS


Options Tried :

------------------------


I saw similar errors reported in the mailing list (copied in the To list ) and tried the following changes in this file :  /usr/sbin/oo-accept-broker 



Tried modifying 

scl enable ruby193 "bundle exec \"$ \""


to


scl enable ${SCLS} "bundle exec \"$ \""


based on inputs from https://github.com/detiber/origin-server/commit/bca4f967b1b8cda1ecc6cb976aea6e2518271d11


But Still same error.


Also based on inputs from mailing list ,tried  modifying safe_bundle "ruby -I ${OSO_BROKER_ROOT} -r rubygems --" <<EOF to

safe_bundle "oo-ruby -I ${OSO_BROKER_ROOT} -r rubygems --" <<EOF


But Still same error.


Also while tring to access broker via browser gives the following :An error has occurred  

You can try refreshing the page, if the problem is temporary.

You can also try the following:

Any pointers will be really helpfull. I have not done any additional configuration other listed in documention of oo-install .


Thanks for the support !!!


Shabna








[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]