[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Origin 4 on RHEL 6.5





2015-01-13 19:11 GMT+00:00 Miciah Dashiel Butler Masters <mmasters redhat com>:
On Tue, Jan 13, 2015 at 04:43:36PM +0100, Massimiliano Dessě wrote:
Hi all,
I've installed origin 4 on RHEL  6.5
in a vmware infrastructure,
(deploy with one broker and two nodes)
with the oo_deployment_guide_comprehensive.
When I execute the oo-diagnostics on the node  I receive the follows errors
in the nodes

[root node02 ~]# oo-diagnostics
FAIL: run_script
oo-accept-node had errors:
--BEGIN OUTPUT--
FAIL: service ruby193-mcollective not running
FAIL: Could not get SELinux context for ruby193-mcollective
eth0: error fetching interface information: Device not found
FAIL: tc htb qdisc not configured

Are you using a different network interface from eth0? If so, you may
have some configuration where you need to substitute the correct name.
Verify that the EXTERNAL_ETH_DEV setting in /etc/openshift/node.conf is
correct.  Your DHCP configuration may also need to be fixed if it has
the wrong interface name.

in /etc/openshift/node.conf there is EXTERNAL_ETH_DEV=bond0
 

3 ERRORS

--END oo-accept-node OUTPUT--
FAIL: test_services_enabled
     The following service(s) are not currently started:
       ruby193-mcollective
     These services are required for OpenShift functionality.

Are there any error messages in
/var/lib/openshift/ruby193-mcollective.log?

No


FAIL: test_mcollective_context
     Mcollectived is not running in the expected SELinux context, which
     may result in node execution failures. Please check that the correct
     context is set on /opt/rh/ruby193/root/usr/sbin/mcollectived and that
the correct SELinux
     policies are loaded.
       Expected: system_r:openshift_initrc_t:s0-s0:c0.c1023
       Found: system_r:openshift_initrc_t:s0-s0:c0.c1023
system_u:system_r:openshift_initrc_t:s0-s0:c0.c1023
unconfined_u:system_r:openshift_initrc_t:s0-s0:c0.c1023
unconfined_u:system_r:openshift_initrc_t:s0-s0:c0.c1023

I've "fixed"
with the content of this http://lists.openshift.redhat.com/openshift-archives/users/2013-December/msg00107.html
(chcon -t openshift_initrc_exec_t /etc/init.d/ruby193-mcollective)

 

What does `pgrep -f mcollectived` show? This error message likely comes
about because MCollective is not running and the test is misinterpreting
output from the ps command.

2726
seem up, but the command
# service ruby193-mcollective status
show
"mcollectived is stopped"
 

3 ERRORS


Does anyone know how to fix this types of errors ?

The devices on the instance are:
bond0     Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
em1       Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
em2       Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
lo        Link encap:Local Loopback

Thanks in advance.
Max

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


--
Miciah Dashiel Butler Masters <mmasters redhat com>



--

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]