[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

weird networking on one of the host



From my limited understanding of openshift networking,containers'  virtual interfaces should be connected to "br0" of ovs and an endpoint of ethernet pair  "vlinuxbr " in linux bridge "lbr0".Strangely one of the host connects all virtual interfaces of containers in "lbr0"  instead of "br0" and it also has issue reaching registry container over 10.1.0.2.


host with networking issue:

brctl show
bridge name     bridge id               STP enabled     interfaces
docker0         8000.56847afe9799       no
lbr0            8000.02cc408da35d       no              veth5d2051f
                                                                                  veth7cc84ca
                                                                                  veth91f1b5d
                                                                                  vlinuxbr

other hosts with working network

brctl show
bridge name     bridge id               STP enabled     interfaces
docker0         8000.56847afe9799       no
lbr0            8000.6aa45a525131       no              vlinuxbr


If i manually create a container using "docker run " it gets connected to "lbr0" of linux bridge but containers created through openshift get connected to ovs bridge except one host.What could be the reason for one of the host to behave strangely.

Thanks for any help

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]