[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

OpenShift 3 Application Lifecycle Sample: Build of frontend fails



I have OpenShift V3 installed with ansible. I have master with 2 nodes. I tried to create the 'OpenShift 3 Application Lifecycle Sample'. (I already did it on a project where OpenShift was running in a Docker container and it worked fine). Now it fails with the following error:
Couldn't create initial deployment: DeploymentConfig "frontend" is invalid: triggers[0].imageChange.tag: invalid value 'latest', Details: no image recorded for test/origin-ruby-sample:latest
The build fails so there isn't a deployment. There aren't build-logs because it looks there was no build. I thought the problem was accessing Docker Hub to get the image but I'm able to login on Docker from my console + I can pull the ruby-20-centos7-image manually.
The build+deploy of the database works fine. I have just the same problem with my cake-php-mysql-example. The database is also fine but the frontend fails with the same error. Even the cake-php example without database is failing. But it all works fine when I'm doing a s2i-build of a php-project in a gitrepo.
When I'm trying a docker build (from s2I) it also fails with the same error. So when I'm trying to create a docker image from a docker file (nginx in my case).
I don't know if it's useful to show the logs of the docker registry because I would think it wouldn't go till the docker registry because the error is much earlier. When I'm searching on appnames in the registry I don't find them so no logs.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]