[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShiftV3: pods keep restarting



Hi,
You need to specify required environment variables [1]. In case of MySQL, you need to run the new-app as follows:

oc new-app mysql -e MYSQL_USER=user,MYSQL_PASSWORD=pass,MYSQL_DATABASE=db

[1] https://ci.openshift.redhat.com/openshift-docs-master-testing/latest/using_images/db_images/mysql.html#environment-variables

Martin

On Fri, Oct 16, 2015 at 12:31 PM, Lorenz Vanthillo <lorenz vanthillo outlook com> wrote:
I'm creating an app from an image:
oc new-app mysql
oc new-app postgresql
oc new-app php
...

I get this output (no build because it's directly from an image)
NOTICE: Image "mysql-55-centos7" uses an EmptyDir volume. Data in EmptyDir volumes is not persisted across deployments.
deploymentconfigs/mysql-55-centos7
services/mysql-55-centos7
Service "mysql-55-centos7" created at 172.30.175.127 with port mappings 3306.
Run 'oc status' to view your app.

It looks fine. But when I'm accessing my webconsole. The pod turns orange after a few seconds.
The events shows the following:

Created with docker id 7e36b1b1d915
12:26:27 PM wordpress-1-oci1v Pod started Started with docker id 7e36b1b1d915
12:26:26 PM wordpress-1-oci1v Pod pulled Container image "library/wordpress sha256:a9f20ce35f723c2afdd12050ba1eca0212ef5b7045d1bfdb2d1d6eac2c05d5cd" already present on machine (54 times in the last 8 minutes, 50 seconds)
12:26:26 PM php-55-centos7-1-hw5qq Pod started Started with docker id 4da4a7592613
12:26:25 PM php-55-centos7-1-hw5qq Pod created Created with docker id 4da4a7592613
12:26:23 PM php-55-centos7-1-hw5qq Pod pulled Successfully pulled image "openshift/php-55-centos7 sha256:368bc240f569c08684b7c7daabeedd46051a8e4316d6ddbe09f68169c56cd1e3" (34 times in the last 5 minutes, 29 seconds)
12:26:22 PM php-55-centos7-1-hw5qq Pod pulling Pulling image "openshift/php-55-centos7 sha256:368bc240f569c08684b7c7daabeedd46051a8e4316d6ddbe09f68169c56cd1e3" (34 times in the last 6 minutes, 9 seconds)




It looks like it keeps pulling, recreating, starting the pod.
This isn't happening when I'm creatin an application from source code
oc new-app www.github.com/sourcecode

And it's also not happening when I'm using templates like php-mysq-example, sample-app, ..

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]