[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HTPasswdPassword



It's not an auth error, the connection is actually refused which tends to indicate the master is not running. Check the master logs for clues (bump up --loglevel if necessary). I assume that your #comment after "file:" is not actually in the conf file; not sure yaml would parse that the way you intend. There could be an selinux reason why the file can't be read (try setenforce 0 to see if it changes), or a format / version problem (master logs should point the way).

On Thu, Oct 22, 2015 at 4:22 AM, Lorenz Vanthillo <lorenz vanthillo outlook com> wrote:
I'm able to login with every user with this (standard config)

identityProviders:
  - name: allow_all
    challenge: True
    login: True
    provider:
      apiVersion: v1
      kind: AllowAllPasswordIdentityProvider     
  masterCA: ca.crt
  masterPublicURL: https://ec2-52-18-247-58.eu-west-1.compute.amazonaws.com:8443
  masterURL: https://ip-10-0-0-104.eu-west-1.compute.internal:8443

With the following configration it's not able to login. I get a 401.

identityProviders:
  - name: deny_all
    challenge: True
    login: True
    provider:
      apiVersion: v1
      kind: DenyAllPasswordIdentityProvider 
  masterCA: ca.crt

  masterPublicURL: https://ec2-52-18-247-58.eu-west-1.compute.amazonaws.com:8443
  masterURL: https://ip-10-0-0-104.eu-west-1.compute.internal:8443


So that's fine, but when I'm trying to use HTPasswdPasswordIdentityProvider with the following config:

identityProviders:
  - name: htpasswd
    challenge: True
    login: True
    provider:
      apiVersion: v1
      kind: HTPasswdPasswordIdentityProvider  
      file: /etc/origin/users.htpasswd #this file exsists and is created in the right way 

  masterCA: ca.crt
  masterPublicURL: https://ec2-52-18-247-58.eu-west-1.compute.amazonaws.com:8443
  masterURL: https://ip-10-0-0-104.eu-west-1.compute.internal:8443

I get the following error:
[root ip-10-0-0-104 master]# oc login
The connection to the server ip-10-0-0-104.eu-west-1.compute.internal:8443 was refused - did you specify the right host or port?

What am I doing wrong?

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]