[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Can't access hawkular-metrics.dev.test.co



Sorry got it:

{
  "kind": "Status",
  "apiVersion": "v1",
  "metadata": {},
  "status": "Failure",
  "message": "User \"system:anonymous\" cannot \"get\" on \"/hawkular/metrics/status\"",
  "reason": "Forbidden",
  "details": {},
  "code": 403
}



From: dencowboy hotmail com
To: mwringe redhat com
CC: users lists openshift redhat com
Subject: RE: Can't access hawkular-metrics.dev.test.co
Date: Mon, 4 Apr 2016 20:58:14 +0000

Do you mean in my browser and with the IP of the node where my router is on?

> Date: Mon, 4 Apr 2016 16:51:55 -0400
> From: mwringe redhat com
> To: dencowboy hotmail com
> CC: users lists openshift redhat com
> Subject: Re: Can't access hawkular-metrics.dev.test.co
>
> Please try this:
>
> > > Are you able to access the Hawkular Metrics server directly with its ip
> > > address? eg https://$IP_ADDRESS:8443/hawkular/metrics/status (or port 8444
> > > if running the OSE metric images)
>
> ----- Original Message -----
> > From: "Den Cowboy" <dencowboy hotmail com>
> > To: "Matt Wringe" <mwringe redhat com>
> > Cc: users lists openshift redhat com
> > Sent: Monday, April 4, 2016 4:48:44 PM
> > Subject: RE: Can't access hawkular-metrics.dev.test.co
> >
> > It's no router/DNS issue because other apps are working fine.
> >
> > I had those errors between the startup but I don't know if it's normal:
> >
> > Readiness probe failed: Failed to access the status endpoint : HTTP Error
> > 404: Not Found.
> >
> >
> >
> >
> >
> >
> > 10:44:40 PM
> >
> >
> > hawkular-metrics-b6qq2
> >
> > Pod
> >
> > Warning
> >
> >
> > Unhealthy
> >
> >
> >
> > Readiness probe failed: Failed to access the status endpoint : <urlopen error
> > [Errno 111] Connection refused>.
> >
> >
> >
> > > Date: Mon, 4 Apr 2016 14:51:43 -0400
> > > From: mwringe redhat com
> > > To: dencowboy hotmail com
> > > CC: users lists openshift redhat com
> > > Subject: Re: Can't access hawkular-metrics.dev.test.co
> > >
> > > ----- Original Message -----
> > > > From: "Den Cowboy" <dencowboy hotmail com>
> > > > To: users lists openshift redhat com
> > > > Sent: Monday, April 4, 2016 11:50:07 AM
> > > > Subject: Can't access hawkular-metrics.dev.test.co
> > > >
> > > > We use the official docs to deploy cluster metrics:
> > > > https://docs.openshift.org/latest/install_config/cluster_metrics.html
> > > > Everything is working fine, the pods are running. Everything seems to
> > > > work
> > > > fine but we're unable to use the route to our hawkular-metrics service.
> > > >
> > > > Browser error: Secure connection failed
> > > >
> > > > curl -X GET https://hawkular-metrics.dev.co/hawkular/metrics/status
> > > > curl: (35) Encountered end of file
> > > >
> > > > We've created our secret this way:
> > > > oc secrets new metrics-deployer nothing=/dev/null
> > >
> > > Are you able to access the Hawkular Metrics server directly with its ip
> > > address? eg https://$IP_ADDRESS:8443/hawkular/metrics/status (or port 8444
> > > if running the OSE metric images)
> > >
> > > Are you sure you properly setup your router and have it exposing that route
> > > properly to the network you are trying to reach this from?
> >

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]