[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: openshift docker install; webconsole binds to false interface



You can tell the webconsole what host to use with --public-master=https://external-host-or-ip:8443

On Tue, Apr 12, 2016 at 9:47 AM, christian staffa <christian p staffa gmail com> wrote:
Hi all

I have been testing openshift installation but I stumbled over the following problem.

I use a centos 7 server with the several nics configured; e.g.
docker0, vnet1, vnet2, virbr0, virbr1, em1 etc.

When I follow the docker installation process noted at
https://docs.openshift.org/latest/getting_started/administrators.html#running-in-a-docker-container
all the process of installation goes well. But when I am trying to open the web console on
https://SERVER:8443/console/
I got an error with 'connection refused'.

I tried to forward the port 8443 from the container with '-p 8443:8443' on starting the docker container
and I got access to the console BUT there happens a redirect and the browser is trying to load:
https://192.168.0.100:8443/console/
This is the virbr0 bridge adapter.

Is there a way to set the proper interface for binding of the webconsole with the docker install method?
Does anyone have similar problems?

Thanks for comments :)

Regards

   Chris

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]