[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Build fails with 'Response from registry is: no basic auth credentials' when pushing image



On 2016-08-01 19:50, Ben Parees wrote:

On Fri, Jul 29, 2016 at 9:03 AM, Andre Esser wrote:

    Hi,

    After re-deploying the integrated registry with

      oc delete svc/docker-registry dc/docker-registry

    followed by

      oadm registry --config=/etc/origin/master/admin.kubeconfig
    --service-account=registry

    all builds are now failing with:

      I0729 12:54:21.879110       1 sti.go:269] No push secret provided
      I0729 12:54:21.879139       1 sti.go:271] Pushing
    10.168.43.55:5000/openshifttest2/php-test-2:latest
    <http://10.168.43.55:5000/openshifttest2/php-test-2:latest> image ...
      F0729 12:55:11.895056 1 builder.go:204] Error: build error: Failed
    to push image. Response from registry is: no basic auth credentials



​your push spec appears to be "openshifttest2" and i'm guessing your
project name you actually want to be pushing to is "openshift-test"
since your project below is openshift-test?
​
What is your project name and what is the buildconfig output target?

Apologies, I've had the identical error with a number of projects, including 'openshift-test' and 'openshifttest2'.

However I have been able to rectify the missing credentials error now by:

1. completely removing the registry deployment, including all services, DCs, RCs and pods

2. restarting origin-master-api.service on all masters

3. redeploying built-in registry

4. restarting origin-master-api.service on all masters again (to flush caches)


I hadn't done the restart in step 2. in previous attempts.

I'm now occasionally seeing "Failed to push image. [...] no route to host" errors, but they are reported by others as well, so probably not related to my initial problem.


Cheers,

Andre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]