[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShift origin cluster in VLAN



I've changed the master-ip setting inside my master-config.yaml (which was still on the pub-ip of the installation). I replaced it with my private ip and restarted the cluster.

NAME         ENDPOINTS                                               AGE
kubernetes   192.168.20.1:8053,192.168.20.1:8443,192.168.20.1:8053   19h

I'm able to deploy my router + registry (images are pulled form a private registry in the same VLAN).
But I'm not able to authenticate on my registry. I didn't secure it yet.

docker login -u admin -e any mail com -p `oc whoami -t` 172.30.250.73:5000
Error response from daemon: no successful auth challenge for http://172.30.250.73:5000/v2/ - errors: [basic auth attempt to http://172.30.250.73:5000/v2/ realm "openshift" failed with status: 400 Bad Request]





Van: Clayton Coleman <ccoleman redhat com>
Verzonden: woensdag 7 december 2016 14:56:30
Aan: Den Cowboy
CC: users lists openshift redhat com
Onderwerp: Re: OpenShift origin cluster in VLAN
 
Each master still needs an IP registered that then backs the Kubernetes service that clients use to talk to the API.  So verify that each master is reporting the correct IP that is reachable from all nodes to "oc get endpoints kubernetes -n defaults"

On Dec 7, 2016, at 9:39 AM, Den Cowboy <dencowboy hotmail com> wrote:

We've installed OpenShift origin with the advanced playbook. There we used public ip's. But after the installation we've deleted the public ip's. The master and nodes are in a VLAN. I'm able to create a user, authenticate, visite the webconsole. restart node, master configs. I'm able to pull images from our local registry but I'm not able to do a deployment.


couldn't get deployment default/router-5: Get https://172.30.0.1:443/api/v1/namespaces/default/replicationcontrollers/router-5: dial tcp 172.30.0.1:443: getsockopt: network is unreachable

I'm even not able to curl the kubernetes service. What did we forgot/did wrong?

In our configs the dnsIP: option is in comment. So we did not specifiy it. The docker, origin-node, origin-master and openvswitch services are all running.

Logs of our origin-node show:
pkg/proxy/config/api.go:60: Failed to watch *api.Endpoints: Get https://master.xxx...ction refused
pkg/kubelet/kubelet.go:259: Failed to watch *api.Node: Get https://master.xxx:8443/..
pkg/kubelet/config/apiserver.go:43: Failed to watch *api.Pod
pkg/proxy/config/api.go:47: Failed to watch *api.Service: Get https://master.xxx refused


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]