[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Impossible to restart vagrant VM after one vagrant halt



More information :

* vagrant up master --no-provision
* vagrant halt master
* vagrant up master --no-provision
* vagrant ssh

all work perfectly

but

* vagrant provision master
* vagrant halt master
* vagrant up master
* vagrant ssh

I have :

```
==> master: Configuring and enabling network interfaces...
 INFO ssh: SSH is ready!
 INFO ssh: Execute:  (sudo=false)
 INFO guest: Execute capability: configure_networks [#<Vagrant::Machine: master (VagrantPlugins::ProviderVirtualBox::Provider)>, [{:type=>:static, :adapter_ip=>"192.168.100.1", :ip=>"192.168.100.100", :netmask=>"255.255.255.0", :auto_config=>true, :interface=>1}]] (redhat)
 INFO ssh: SSH is ready!
 INFO ssh: Execute:  (sudo=false)
 INFO guest: Execute capability: flavor [#<Vagrant::Machine: master (VagrantPlugins::ProviderVirtualBox::Provider)>] (redhat)
 INFO ssh: Execute: cat /etc/redhat-release (sudo=true)
 INFO ssh: SSH is ready!
 INFO ssh: Execute:  (sudo=false)
 INFO guest: Execute capability: network_scripts_dir [#<Vagrant::Machine: master (VagrantPlugins::ProviderVirtualBox::Provider)>] (redhat)
 INFO ssh: Execute: /usr/sbin/biosdevname &>/dev/null; echo $? (sudo=true)
 INFO ssh: Execute: ls /sys/class/net | egrep -v lo\|docker (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/br0/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/eth0/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/eth1/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/lbr0/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/ovs-system/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/tun0/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/vlinuxbr/address (sudo=true)
 INFO ssh: Execute: cat /sys/class/net/vovsbr/address (sudo=true)
 INFO ssh: Execute: touch /etc/sysconfig/network-scripts/ifcfg-eth0 (sudo=true)
 INFO ssh: Execute: sed -e '/^#VAGRANT-BEGIN/,/^#VAGRANT-END/ d' /etc/sysconfig/network-scripts/ifcfg-eth0 > /tmp/vagrant-ifcfg-eth0 (sudo=true)
 INFO ssh: Execute: cat /tmp/vagrant-ifcfg-eth0 > /etc/sysconfig/network-scripts/ifcfg-eth0 (sudo=true)
 INFO ssh: Execute: rm -f /tmp/vagrant-ifcfg-eth0 (sudo=true)
 INFO ssh: Execute: cat /tmp/vagrant-network-entry_eth0 >> /etc/sysconfig/network-scripts/ifcfg-eth0

if command -v nmcli &>/dev/null; then
  if command -v systemctl &>/dev/null && systemctl -q is-enabled NetworkManager &>/dev/null; then
    nmcli c reload eth0
  elif command -v service &>/dev/null && service NetworkManager status &>/dev/null; then
    nmcli c reload eth0
  fi
fi

/sbin/ifdown eth0
/sbin/ifup eth0

rm -f /tmp/vagrant-network-entry_eth0
 (sudo=true)
```

and nothing, impossible to execute vagrant ssh

Have you some idea ?



2016-01-29 10:37 GMT+01:00 Stéphane Klein <contact stephane-klein info>:
Hi,

what I did :

```
$ git clone git github com:openshift/openshift-ansible.git
$ cd openshift-ansible
$ vagrant up --no-provision
$ vagrant provision
$ vagrant status
node1                     running (virtualbox)
node2                     running (virtualbox)
master                    running (virtualbox)
$ vagrant halt
$ vagrant up --no-provision
Bringing machine 'node1' up with 'virtualbox' provider...
Bringing machine 'node2' up with 'virtualbox' provider...
Bringing machine 'master' up with 'virtualbox' provider...
==> node1: Checking if box 'centos/7' is up to date...
==> node1: Clearing any previously set forwarded ports...
==> node1: Clearing any previously set network interfaces...
==> node1: Preparing network interfaces based on configuration...
    node1: Adapter 1: nat
    node1: Adapter 2: hostonly
==> node1: Forwarding ports...
    node1: 22 (guest) => 2222 (host) (adapter 1)
==> node1: Running 'pre-boot' VM customizations...
==> node1: Booting VM...
==> node1: Waiting for machine to boot. This may take a few minutes...
    node1: SSH address: 127.0.0.1:2222
    node1: SSH username: vagrant
    node1: SSH auth method: private key
    node1: Warning: Remote connection disconnect. Retrying...
==> node1: Machine booted and ready!
==> node1: Checking for guest additions in VM...
    node1: No guest additions were detected on the base box for this VM! Guest
    node1: additions are required for forwarded ports, shared folders, host only
    node1: networking, and more. If SSH fails on this machine, please install
    node1: the guest additions and repackage the box to continue.
    node1:
    node1: This is not an error message; everything may continue to work properly,
    node1: in which case you may ignore this message.
==> node1: Setting hostname...
==> node1: Configuring and enabling network interfaces...
"""

And nothing…

Are there firewall or other think like this in VM that block ssh connection on port 2222 ?

Best regards,
Stéphane



--
Stéphane Klein <contact stephane-klein info>
blog: http://stephane-klein.info
cv : http://cv.stephane-klein.info
Twitter: http://twitter.com/klein_stephane

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]