[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Adding a node to the cluster without ansible



> Also Please update with latest relevant information on redhat portal page

> https://access.redhat.com/solutions/1983683

Sorry, that's my task. I updated it to link this page https://access.redhat.com/solutions/2150381

Thanks,
Kenjiro

On Fri, Feb 5, 2016 at 3:10 AM, Srinivas Naga Kotaru (skotaru) <skotaru cisco com> wrote:
Also Please update with latest relevant information on redhat portal page


-- 
Srinivas Kotaru

From: <users-bounces lists openshift redhat com> on behalf of skotaru <skotaru cisco com>
Date: Thursday, February 4, 2016 at 10:04 AM
To: v <vekt0r7 gmx net>

Cc: "users lists openshift redhat com" <users lists openshift redhat com>
Subject: Re: Adding a node to the cluster without ansible

Will ansible will touch existing configuration  and by any chance it will  overwrite custom config put into ? 

Just adding a new node, steps required looks scare me ( both ansible and manual). Can we do better job here by automating this task and guaranteed no disruption to existing cluster health?

My worry about real prod environments and always uptime guaranteed with SLA’s. 

-- 
Srinivas Kotaru

From: <users-bounces lists openshift redhat com> on behalf of v <vekt0r7 gmx net>
Date: Thursday, February 4, 2016 at 7:51 AM
Cc: "users lists openshift redhat com" <users lists openshift redhat com>
Subject: Re: Adding a node to the cluster without ansible

Nice one, scaleup.yml is a very good idea!

origin-sdn-ovs is installed on the node, but it was a 1.0.x node. After the update to 1.1 the error is gone. :)

Will create a PR for the instructions.

Am 2016-02-04 um 16:40 schrieb Jason DeTiberus:
I would like to add an additional node to the cluster without using ansible.
(We have modified our cluster in many ways and don't dare running ansible because it might break our cluster.)

 The scale up playbooks take this into account.

They will query the master, generates and distributes the new certificates for the new node, and then runs the config playbooks on the new nodes only.

To take advantage of this,  you will need to add a group to your inventory called [new_nodes] and configure the hosts as you would for a new install under the [nodes] group.
Then you would run the playbooks/byo/openshift-cluster/scaleup.yml playbook.


On Thu, Feb 4, 2016 at 9:55 AM, v <vekt0r7 gmx net> wrote:
All right, looks like it works. These are the commands for the master with 3.1:

oadm create-api-client-config \
      --certificate-authority=/etc/origin/master/ca.crt \
      --client-dir=/root/xyz4 \
      --master=https://xyz1.eu:8443 \
      --signer-cert=/etc/origin/master/ca.crt \
      --signer-key=/etc/origin/master/ca.key \
      --signer-serial=/etc/origin/master/ca.serial.txt \
--groups=system:nodes \
--user=system:node:xyz4.eu

oadm create-node-config \
--node-dir=/root/xyz4 \
--node=xyz.eu \
--hostnames=xyz4.eu,123.456.0.5 \
--certificate-authority /etc/origin/master/ca.crt \
--signer-cert /etc/origin/master/ca.crt \
--signer-key /etc/origin/master/ca.key \
--signer-serial /etc/origin/master/ca.serial.txt \
--master=https://xyz1.eu:8443 \
--node-client-certificate-authority /etc/origin/master/ca.crt

Then I copied all the created files to /etc/origin/node on the new node.
Took node-config.yaml from an old, working node, edited the hostnames and used it as node-config.yaml on the new node.

It seems to work. The only thing that bugs me is that I'm being spammed with the following error on the new node:
manager.go:313] NetworkPlugin redhat/openshift-ovs-subnet failed on the status hook for pod 'xy-router-2-imubn' - exit status 1
manager.go:313] NetworkPlugin redhat/openshift-ovs-subnet failed on the status hook for pod 'ipf-default-1-dp4vc' - exit status 1

Do you mind submitting a PR or an issue to the openshift-docs repo for these steps? https://github.com/openshift/openshift-docs
 

Can anyone tell me if this is something important or whether there are additional steps needed that I have missed?

It sounds like you are missing the -sdn-ovs package on the new node host. If you are running Origin, then it would be origin-sdn-ovs, otherwise it is atomic-enterprise-sdn-ovs.
 

Regards,
v


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users




--
Kenjiro NAKAYAMA <nakayamakenjiro gmail com>
GPG Key fingerprint = ED8F 049D E67A 727D 9A44  8E25 F44B E208 C946 5EB9

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]