[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShift with Docker method installation on CentOS, error : deployer.go:65] couldn't get deployment default/docker-registry-1: Get https://10.0.2.15:8443/api/v1/namespaces/default/replicationcontrollers/docker-registry-1: dial tcp 10.0.2.15:8443: no route to host



Same error with Docker Origin image version 1.1.2

More info :

```
[root localhost vagrant]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:aa:92:14 brd ff:ff:ff:ff:ff:ff
    inet 10.0.2.15/24 brd 10.0.2.255 scope global dynamic enp0s3
       valid_lft 83250sec preferred_lft 83250sec
    inet6 fe80::a00:27ff:feaa:9214/64 scope link
       valid_lft forever preferred_lft forever
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN
    link/ether 02:42:55:74:29:18 brd ff:ff:ff:ff:ff:ff
    inet 172.17.42.1/16 scope global docker0
       valid_lft forever preferred_lft forever
    inet6 fe80::42:55ff:fe74:2918/64 scope link
       valid_lft forever preferred_lft forever
[root localhost vagrant]# brctl show
bridge name    bridge id        STP enabled    interfaces
docker0        8000.024255742918    no
```


2016-02-10 8:34 GMT+01:00 Stéphane Klein <contact stephane-klein info>:
Hi,

I've installed OpenShift with Docker method ( https://docs.openshift.org/latest/getting_started/administrators.html#running-in-a-docker-container ) on CentOS Linux release 7.2.1511 (Core)

```
# docker run -d --name "origin" --privileged --pid=host --net=host -v /:/rootfs:ro -v /var/run:/var/run:rw -v /sys:/sys -v /var/lib/docker:/var/lib/docker:rw -v /var/lib/origin/openshift.local.volumes:/var/lib/origin/openshift.local.volumes openshift/origin:v1.1.1.1 start
# docker exec -it origin bash
# oc login -u system:admin
# oc project default
# oadm registry --credentials=./openshift.local.config/master/openshift-registry.kubeconfig
# oc logs docker-registry-1-deploy
F0209 22:00:19.098482       1 deployer.go:65] couldn't get deployment default/docker-registry-1: Get https://10.0.2.15:8443/api/v1/namespaces/default/replicationcontrollers/docker-registry-1: dial tcp 10.0.2.15:8443: no route to host
```

But ```10.0.2.15:8443``` is accessible :

```
# curl https://10.0.2.15:8443/api/v1/namespaces/default/replicationcontrollers/docker-registry-1 --insecure
{
  "kind": "Status",
  "apiVersion": "v1",
  "metadata": {},
  "status": "Failure",
  "message": "User \"system:anonymous\" cannot get replicationcontrollers in project \"default\"",
  "reason": "Forbidden",
  "details": {
    "name": "docker-registry-1",
    "kind": "replicationcontrollers"
  },
  "code": 403
}
```

Where is my mistake ?

Best regards,
Stéphane

--



--
Stéphane Klein <contact stephane-klein info>
blog: http://stephane-klein.info
cv : http://cv.stephane-klein.info
Twitter: http://twitter.com/klein_stephane

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]