[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OpenShift with Docker method installation on CentOS, error : deployer.go:65] couldn't get deployment default/docker-registry-1: Get https://10.0.2.15:8443/api/v1/namespaces/default/replicationcontrollers/docker-registry-1: dial tcp 10.0.2.15:8443: no route to host



Firewall it is :)

On Feb 10, 2016, at 5:42 AM, Stéphane Klein <contact stephane-klein info> wrote:

```
root d2a1ccf29589:/# nmap 10.0.2.15

Starting Nmap 6.40 ( http://nmap.org ) at 2016-02-10 01:40 UTC
Nmap scan report for 10.0.2.15
Host is up (0.000092s latency).
Not shown: 999 filtered ports
PORT   STATE SERVICE
22/tcp open  ssh

Nmap done: 1 IP address (1 host up) scanned in 19.78 seconds
```

Only ssh port is open :(


2016-02-10 11:35 GMT+01:00 Stéphane Klein <contact stephane-klein info>:
More info, I can ping, but port 8443 isn't open ?

```
root d2a1ccf29589:/# ping 10.0.2.15
PING 10.0.2.15 (10.0.2.15) 56(84) bytes of data.
64 bytes from 10.0.2.15: icmp_seq=1 ttl=64 time=0.059 ms
root d2a1ccf29589:/# telnet 10.0.2.15 8443
Trying 10.0.2.15...
telnet: Unable to connect to remote host: No route to host
```


2016-02-10 11:10 GMT+01:00 Stéphane Klein <contact stephane-klein info>:


2016-02-10 10:48 GMT+01:00 Clayton Coleman <ccoleman redhat com>:
Might be a firewall rule - try connecting to 10.0.2.15 from a random docker container on the machine.



Yes I can :

```
[root localhost vagrant]# docker run -t -i ubuntu /bin/bash
root b4e25a365497:/# ping 10.0.2.15
PING 10.0.2.15 (10.0.2.15) 56(84) bytes of data.
64 bytes from 10.0.2.15: icmp_seq=1 ttl=64 time=0.084 ms
64 bytes from 10.0.2.15: icmp_seq=2 ttl=64 time=0.079 ms
```

Clayton, are you on irc ? If yes, can I contact you to help me to debug that ? (I'm harobed3)

Best regards,
Stéphane



--



--

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]