[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pods hanging in "pending" state



What is "i\u200b"?  Is that a unicode character?

On Thu, Feb 18, 2016 at 4:23 PM, Candide Kemmler
<candide intrinsic world> wrote:
> No there is no readiness proble in place.
>
> Really strange: here's what `oc get dc intrinsic-pds -o yaml` tells me:
>
> Error from server: deploymentConfig "i\u200bntrinsic-pds" not found
>
> ???
>
> On 18 Feb 2016, at 22:10, Dan Mace <dmace redhat com> wrote:
>
> On Thu, Feb 18, 2016 at 4:03 PM, Candide Kemmler <candide intrinsic world>
> wrote:
>>
>> I have successfully created templates for all 5 microservices in our
>> application but now, at the "deployment" phase, the pod will remain
>> "pending" and even deleting all related objects will not get rid of it and
>> it will remain forever at the bottom of the overview list with an orange
>> circle around it. I can see that the s2i phase completed successfully, the
>> replicationcontroller duly created the pod which was assigned a node, as is
>> shown in the logs:
>>
>>
>> 9:53:18 PM      intrinsic-pds-1-7fohj   Pod     Scheduled
>> Successfully assigned intrinsic-pds-1-7fohj to apps.intrinsic.world
>> 9:53:18 PM      intrinsic-pds-1 ReplicationController   SuccessfulCreate
>> Created pod: intrinsic-pds-1-7fohj
>> 9:53:15 PM      intrinsic-pds-1-deploy  Pod     Scheduled
>> Successfully assigned
>> i
>> ntrinsic-pds-1-deploy to apps.intrinsic.world
>>
>> The deployment, which will be forever "running" seems to be stuck saying
>> the following:
>>
>>
>> I0218 20:52:12.846055 1 deployer.go:196] Deploying
>> intrinsic-dev/intrinsic-pds-1 for the first time (replicas: 1)
>> I0218 20:52:12.848446 1 recreate.go:105] Scaling
>> intrinsic-dev/intrinsic-pds-1 to 1 before performing acceptance check
>> I0218 20:52:14.909059 1 recreate.go:110] Performing acceptance check of
>> intrinsic-dev/intrinsic-pds-1
>> I0218 20:52:14.909455 1 lifecycle.go:379] Waiting 600 seconds for pods
>> owned by deployment "intrinsic-dev/intrinsic-pds-1" to become ready
>> (checking every 1 seconds; 0 pods previously accepted)
>>
>> Other than by destroying the entire project (that works), how can I get
>> rid of these buggy pods and more importantly, how can I debug what's
>> affecting my deployments?
>
>
> The deployment is waiting up to 10 minutes to verify that the newly deployed
> version's first pod is ready before progressing. Do you have
>
> any livenessProbe or readinessProbe defined on the pod template inside your
> deploymentConfig? The output of "oc get dc/intrinsic-pds -o yaml" would be
> helpful.
>
>
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]