[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Aggregated Logging Template Fails



Thanks for the quick reply Eric, 

The template appears to be using openshift/origin-logging-deployer:v1.1

I’ll pull the latest version of the repo and give that a go. 

Thanks

From: Eric Wolinetz <ewolinet redhat com>
Date: Wednesday, 24 February 2016 at 12:29 PM
To: Tim Moor <tim moor spring co nz>
Cc: "users lists openshift redhat com" <users lists openshift redhat com>
Subject: Re: Aggregated Logging Template Fails

Hi Tim,

What version of the logging-deployment image is your logging-deployer.yaml file using?
There was a backwards compatibility issue with the previous support-pre-template and the version of origin you're using -- it was specifying a target port for the Elasticsearch headless services which is now validated against differently.

The related commit is here [0].

On Tue, Feb 23, 2016 at 5:18 PM, Tim Moor <tim moor spring co nz> wrote:
Hey list, having a few issues with the Aggregated Logging template provided as part of the default install.

When running the deployer it’s failing with the following errors. I’ve also attached a script I’ve been using to redeploy on failure as part of debugging.

Archtectiure
- aklkvm019.corp   kubernetes.io/hostname=<sanitised>,region=infra,zone=default   Ready     7d
- aklkvm020.corp   kubernetes.io/hostname=<sanitised>,region=primary,zone=east    Ready     7d
- aklkvm021.corp   kubernetes.io/hostname=<sanitised>,region=primary,zone=west    Ready     7d


Software Versions
- origin-1.1.3-0.git.0.8edc1be.el7.centos.x86_64
- origin-node-1.1.3-0.git.0.8edc1be.el7.centos.x86_64
- origin-sdn-ovs-1.1.3-0.git.0.8edc1be.el7.centos.x86_64
- origin-clients-1.1.3-0.git.0.8edc1be.el7.centos.x86_64
- origin-master-1.1.3-0.git.0.8edc1be.el7.centos.x86_64



Errors
- Error from server: Service "logging-es-cluster" is invalid: spec.ports[0].port: Invalid value: 9300: must be equal to targetPort when clusterIP = None
- Error from server: Service "logging-es-ops-cluster" is invalid: spec.ports[0].port: Invalid value: 9300: must be equal to targetPort when clusterIP = None


Any help greatly appreciated.

Tim

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]