[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: LDAP authentication with STARTTLS failing



Good to know, thanks!

On 2016-07-14 15:50, Jordan Liggitt wrote:
Yup, origin 1.2.0 was built with go1.4.

origin 1.3 will be built with go1.6

On Thu, Jul 14, 2016 at 10:48 AM, Andre Esser
<andre esser voidbridge com <mailto:andre esser voidbridge com>> wrote:

    It's version 1.2.0 and I've installed it using the Advanced
    Installation instructions from
    https://docs.openshift.org/latest/install_config/install/advanced_install.html

    Andre


    On 2016-07-14 15:41, Jordan Liggitt wrote:

        What version of origin are you running with (and if you built it
        yourself, what version of go did you build with?)

        It looks like SECURE256 translates to these ciphers:

        |TLSv1.2: ciphers: TLS_RSA_WITH_AES_256_CBC_SHA256
        TLS_RSA_WITH_AES_256_GCM_SHA384 TLS_RSA_WITH_CAMELLIA_256_GCM_SHA384
        |


        None of those are supported in go1.4.
        |TLS_RSA_WITH_AES_256_GCM_SHA384should work with go1.6.|




        On Thu, Jul 14, 2016 at 8:54 AM, Andre Esser
        <andre esser voidbridge com <mailto:andre esser voidbridge com>
        <mailto:andre esser voidbridge com
        <mailto:andre esser voidbridge com>>> wrote:

             RESOLVED:

             Our LDAP servers required 256 bit cyphers but OpenShift
        appears to
             use 128 bit ones. After setting 'olcTLSCipherSuite' to
        'SECURE128'
             authentication started to work.

             Cheers,

             Andre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]