[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Build fails with 'Response from registry is: no basic auth credentials' when pushing image



Hi,

After re-deploying the integrated registry with

  oc delete svc/docker-registry dc/docker-registry

followed by

oadm registry --config=/etc/origin/master/admin.kubeconfig --service-account=registry

all builds are now failing with:

  I0729 12:54:21.879110       1 sti.go:269] No push secret provided
I0729 12:54:21.879139 1 sti.go:271] Pushing 10.168.43.55:5000/openshifttest2/php-test-2:latest image ... F0729 12:55:11.895056 1 builder.go:204] Error: build error: Failed to push image. Response from registry is: no basic auth credentials

A number of posts seem to suggest that this problem is project-specific and that re-creating the project will resolve this. I however get this with all projects, even with brand new ones.


Few more details:

# oc -n default get svc
NAME CLUSTER-IP EXTERNAL-IP PORT(S) AGE
docker-registry   10.168.43.55    <none>        5000/TCP                  2h
kubernetes        10.168.40.1     <none>        443/TCP,53/UDP,53/TCP     3d
router            10.168.40.132   <none>        80/TCP,443/TCP,1936/TCP   2d

# oc -n default get rc
NAME                DESIRED   CURRENT   AGE
docker-registry-1   1         1         2h
router-2            3         3         3h

# oc -n default get pod
NAME                      READY     STATUS    RESTARTS   AGE
docker-registry-1-449d3   1/1       Running   0          2h
router-2-3nkr1            1/1       Running   1          3h
router-2-f3827            1/1       Running   1          3h
router-2-pqgkq            1/1       Running   1          3h


Any help much appreciated,

Andre


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]