[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ImagePullBackOff - API error (500): manifest unknown



See this thread:
http://lists.openshift.redhat.com/openshift-archives/users/2016-June/msg00054.html

you will need to rebuild/push your image using docker1.9 for now.



On Thu, Jun 9, 2016 at 9:23 AM, Henryk Konsek <hekonsek gmail com> wrote:
Hi,

Today one of my images suddenly became undeployable :) I receive ErrImagePull when I try to pull it from Docker Hub:

$ docker exec -it openshift-server oc get pod
NAME                READY     STATUS         RESTARTS   AGE
eventbus-1-deploy   1/1       Running        0          19s
eventbus-1-sa72a    0/1       ErrImagePull   0          10s

Events tells me that error cause is "API error (500): manifest unknown".

$ docker exec -it openshift-server oc get events
12s         12s        1         eventbus-1-sa72a    Pod       spec.containers{eventbus}     Warning   Failed             {kubelet henryberg}    Failed to pull image "smolok/eventbus sha256:cadbd5e4b51ad84784f9b45449645cd86459d536f4fe4a848b08fb75ac0f49af": API error (500): manifest unknown: manifest unknown

12s       12s       1         eventbus-1-sa72a   Pod                 Warning   FailedSync   {kubelet henryberg}   Error syncing pod, skipping: failed to "StartContainer" for "eventbus" with ErrImagePull: "API error (500): manifest unknown: manifest unknown\n"

12s       12s       1         eventbus-1-sa72a   Pod       spec.containers{eventbus}   Normal    BackOff      {kubelet henryberg}   Back-off pulling image "smolok/eventbus sha256:cadbd5e4b51ad84784f9b45449645cd86459d536f4fe4a848b08fb75ac0f49af"
12s       12s       1         eventbus-1-sa72a   Pod                                   Warning   FailedSync   {kubelet henryberg}   Error syncing pod, skipping: failed to "StartContainer" for "eventbus" with ImagePullBackOff: "Back-off pulling image \"smolok/eventbus sha256:cadbd5e4b51ad84784f9b45449645cd86459d536f4fe4a848b08fb75ac0f49af\""

Out of the sudden the image can't be downloaded on all my machines. I still can pull and run the image using bare Docker client.

Any ideas what could be the cause?

Cheers!

--

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users




--
Ben Parees | OpenShift


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]