[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Authentication error no matter what I do



Ok, apparently it was hung up on some previous failed login for some reason. It seems to be working now. Thanks for the help and more info on how to trouble shoot this. It helped regardless.

On Mon, Oct 10, 2016 at 10:43 AM, Dean Peterson <peterson dean gmail com> wrote:
It appears those match. >From what I can tell they are both: "https://srv-dcd00pas02.roomstogo.rtg:8443".  That is in the openshift-web-console config, it is "masterPublicURL" in master-config.yml and it is what appears in the browser when going to the openshift console.

On Mon, Oct 10, 2016 at 10:38 AM, Jordan Liggitt <jliggitt redhat com> wrote:
The URL shown in the user's browser should be the "public master url" given to the configuration.


On Mon, Oct 10, 2016 at 11:33 AM, Dean Peterson <peterson dean gmail com> wrote:
The machine reaches out to the public web by proxy server. Do I need to add the proxy server url as a valid redirectURI?

On Mon, Oct 10, 2016 at 10:13 AM, Dean Peterson <peterson dean gmail com> wrote:

It looks like the URLs in the web-console config and master-config.yaml are correct. Is there something else that can cause this?


On Oct 10, 2016 9:51 AM, "Dean Peterson" <peterson dean gmail com> wrote:
Attached is the contents of my master-config.yaml

On Mon, Oct 10, 2016 at 9:21 AM, Dean Peterson <peterson dean gmail com> wrote:
I did verify that the openshift-web-console contains:

redirectURIs:
https://srv-dcd00pas02.roomstogo.rtg:8443/console/
http://localhost:9000
https://localhost:9000
https://srv-dcd00pas02.roomstogo.rtg:8443 is the URL of the web console.  I will check that the master-config.yaml matches.


On Mon, Oct 10, 2016 at 8:26 AM, Jordan Liggitt <jliggitt redhat com> wrote:
What URL is your web console located at? That is typically seen when the redirectURI of the openshift-web-console OAuthClient doesn't match the URL of the web console.

seeing master-config.yaml and `oc get oauthclient/openshift-web-console -o yaml` would help



On Mon, Oct 10, 2016 at 9:10 AM, Dean Peterson <peterson dean gmail com> wrote:

This is a complete showstopper, does anyone have any ideas?


On Oct 9, 2016 8:51 PM, "Dean Peterson" <peterson dean gmail com> wrote:
Inline image 2

I get the above error when I have standard username and password authentication with htpasswd enabled as well as when I have authentication disabled entirely and use AllowAll. Nothing I do seems to get around this error. I have installed openshift with the ansible installer successfully many times before. Now I can't seem to even get a user logged in.

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users









[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]