[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: First build through UI fails due to missing secret



First, this is a case where additional user-provided credentials are needed for a successful build. The UI doesn't yet provide a way for users to enter secrets during the app creation flow. The work to add this is in progress and tracked in https://trello.com/c/OVlx3edX and is planned for 1.4

Second, the issue with delayed secrets is resolved as of 1.3, so messing with the service accounts isn't necessary.




On Mon, Oct 17, 2016 at 8:19 AM, Diego Castro <diego castro getupcloud com> wrote:

This is a know issue, sometimes builds fail due lack of secrets.
Try delete the following service accounta, dont worry they are recreated automatically:

$ oc delete sa default builder deployer -n <namespace>

Diego Castro
Gmail Android


Em 17 de out de 2016 4:37 AM, "David Strejc" <david strejc gmail com> escreveu:
Is there any way how I can setup first build through UI when cloning
git which requires key / auth?

Now my first build fails and I need to add ssh key as secret to
OpenShift and then rerun build with ssh keys.

Thank you.

David Strejc
https://octopussystems.cz
t: +420734270131
e: david strejc gmail com

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]