[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

HELP - Image pull back off



Hi,

We have updated the OS of our nodes last night, nothing fancy, and since, all projects with built images are failing. This is absolutely scary:

- The site are unavailable, the pod are failing with "Image pull back off"
- We can't deploy anymore
- We can't rollback anymore
- We can't build anymore

This is on a 1.2.1 cluster. We upgraded to 1.2.2 with the same result.
When building, the build is failing at the very end:

E1023 08:54:24.046357       1 dockerutil.go:86] push for image 172.30.201.95:5000/openshift/base-prod:latest failed, will retry in 5s ...

(That's the message from Stéphane earlier).
We don't know why, the build is trying to talk to the registry using https now:

v2 ping attempt failed with error: Get https://172.30.201.95:5000/v2/: http: server gave HTTP response to HTTPS client
 v1 ping attempt failed with error: Get https://172.30.201.95:5000/v1/_ping: http: server gave HTTP response to HTTPS client

We did nothing except rebooting master, etcd, and nodes for the os updates:

Updating from: centos-atomic-host:centos-atomic-host/7/x86_64/standard
1 metadata, 0 content objects fetched; 313 B transferred in 0 seconds
!bind-libs-32:9.9.4-29.el7_2.3-x86_64
=bind-libs-32:9.9.4-29.el7_2.4-x86_64
!bind-libs-lite-32:9.9.4-29.el7_2.3-x86_64
=bind-libs-lite-32:9.9.4-29.el7_2.4-x86_64
!bind-license-32:9.9.4-29.el7_2.3-noarch
=bind-license-32:9.9.4-29.el7_2.4-noarch
!bind-utils-32:9.9.4-29.el7_2.3-x86_64
=bind-utils-32:9.9.4-29.el7_2.4-x86_64
!openssl-1:1.0.1e-51.el7_2.5-x86_64
=openssl-1:1.0.1e-51.el7_2.7-x86_64
!openssl-libs-1:1.0.1e-51.el7_2.5-x86_64
=openssl-libs-1:1.0.1e-51.el7_2.7-x86_64
!tzdata-2016f-1.el7-noarch
=tzdata-2016g-2.el7-noarch

The register is up and running, but nothing unusual in the logs.

Thanks,
Philippe

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]