[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Version of the artifacts supported / OpenShift Release



Hi,

Is it defined somewhere for each OpenShift Artifacts (Template, DeploymentConfig, Buildconfig, ...), the version of the "syntax" supported according to the OpenShift Server (1.2, 1.3, ...) where it will be executed ?
Syntax = Json or YAML Structure supported

Example: The DeploymentConfig Template is described here https://docs.openshift.com/enterprise/latest/dev_guide/deployments.html#dev-guide-deployments for the Api Version = 1
- Is Api  Version 1 the Api supported by OpenShift Origin 1.x ? OpenShift enterprise 3.x ?
- Is it possible to have a Reference Template for each Artifact that we can use top of OpenShift ? Maybe from a Github repo ? 

Regards,

Charles

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]