[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Secrets not available anymore with 1.3.0



Which version of Docker are you running?  Paul, do those propagation settings look correct?

On Tue, Sep 27, 2016 at 3:40 PM, Philippe Lafoucrière <philippe lafoucriere tech-angels com> wrote:
Hi,

We're testing OS 1.3.0 on our test cluster, and have something weird happening.
The secrets are mounted, but apparently not readable anymore in _some_ pods:

This is on openshift 1.2.1:

{
    "Source": "/var/lib/origin/openshift.local.volumes/pods/3f7a5adc-84b1-11e6-8101-005056b12d45/volumes/kubernetes.io~secret/airbrake-secrets",
    "Destination": "/etc/secrets/airbrake",
    "Mode": "ro,Z",
    "RW": false
}

and on openshift 1.3.0:

 {
     "Source": "/var/lib/origin/openshift.local.volumes/pods/19df38db-84e9-11e6-be87-005056b17dcc/volumes/kubernetes.io~secret/airbrake-secrets",
     "Destination": "/etc/secrets/airbrake",
     "Mode": "ro,Z",
     "RW": false,
     "Propagation": "rslave"
 },

Only the propagation is different, but it should not be an issue.
I can't get a shell inside the container, because it's just an executable wrapped inside a "scratch" docker image.

The pods with a shell don't seem to this problem, and I can see the secrets mounted and used as usual.

Any hints?

Thanks,
Philippe


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]