[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Jenkins integration





On Tue, Aug 8, 2017 at 10:52 AM, Thorvald Hallvardsson <thorvald hallvardsson gmail com> wrote:
Hi,

I'm trying to run jenkins on OpenShift to integrate it nicely with pipelines and OAUTH. I have done that in the past and it was all working but I'm trying to reproduce what I used to do before and it simply doesn't work. I don't know why but from one version to another OpenShift is becominbg more and more pain. 

I was following official blog article https://blog.openshift.com/openshift-pipelines-jenkins-blue-ocean/ which used to work however jenkins changed something now and that build simply doesn't work anymore:
Cloning "https://github.com/siamaksade/jenkins-blueocean.git" ...
WARNING: timed out waiting for git server, will wait 1m4s
Commit: 70cff8557908b592d291e6ea0b3a018069b61324 (updated README)
Author: Siamak Sadeghianfar <ssadeghi redhat com>
Date: Thu Apr 6 18:48:41 2017 +0700
---> Copying repository files ...
---> Installing Jenkins 0 plugins using /opt/openshift/plugins.txt ...
Creating initial locks...
Locking blueocean:1.0.0
Analyzing war...
Downloading plugins...
Downloading plugin: blueocean from https://updates.jenkins-ci.org/download/plugins/blueocean/1.0.0/blueocean.hpi
Downloading plugin: blueocean-plugin from https://updates.jenkins-ci.org/download/plugins/blueocean-plugin/1.0.0/blueocean-plugin.hpi
Failed to download plugin: blueocean or blueocean-plugin
Failed to install plugins.
error: build error: non-zero (13) exit code from openshift/jenkins-2-centos7@sha256:ad29fc43c3f9015a0fdbb3f3ba366ff511303f7f3a0bbb1bc4652ecf70eb3712

Simply because second link drops 404... blueocean-plugin.hpi doesn't exist anymore. 

Sounds like some stuff has bit-rotted in that blog, CCing Siamak in case he has time to update it.

But note that we do already install blue ocean in our jenkins centos image and we'll be adding it to our rhel image most likely in 3.7.

 


I decided OK... I don't need blueocean so I will just go for standard Jenkins from OpenShift templates. That did install successfuly but when I click on the link it asks for username and password (on Jenkins screen) so simply OAUTH doesn't work at all. 

The pod has 
# oc exec jenkins-1-28l8x env |grep -i auth
OPENSHIFT_ENABLE_OAUTH=true

it is running but ... yeah how do I integrate it with my pipelines? Any ideas?

Gabe and Mo (on CC) have added some debug for oauth flow failures, what version of openshift are you running and can you provide openshift master logs and jenkins pod logs?


 

Thanks!

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users




--
Ben Parees | OpenShift


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]