[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Upgrade to v3.6.0, "oc adm migrate storage" return many errors like: Forbidden: pod updates may not change fields other than `containers[*].image` or `spec.activeDeadlineSeconds`



Hi,

when I try to upgrade OpenShift Origin v1.5.1 cluster to v3.6.0 I have many errors when Ansible execute « Upgrade all storage » task: https://github.com/openshift/openshift-ansible/blob/release-3.6/playbooks/common/openshift-cluster/upgrades/upgrade_control_plane.yml#L11

Many line errors like:

error:     pods/test-secret-6-qz4ar -n issue-29059: Pod \"test-secret-6-qz4ar\" is invalid: spec: Forbidden: pod updates may not change fields other than `containers[*].image` or `spec.activeDeadlineSeconds`

What is it? How can I fix it?

Best regards,
Stéphane
--

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]