[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

push to registry fail



A BuildConfig that has previously run OK is now failing with a "Push image to registry failed" error. AFAIK nothing relevant has changed in the OpenShift  setup (Origin 3.6), though can't be sure of this. Looking a the logs of the registry pod I see this (note the "permission denied" bit):

time="2017-12-08T17:59:49.580297486Z" level=error msg="response completed with error" err.code=unknown err.detail="filesystem: mkdir /registry/docker/registry/v2/repositories/openrisknet-infra/home/_uploads/99b0e713-2060-4779-87c5-b7b9a27855e3: permission denied" err.message="unknown error" go.version=go1.7.6 http.request.host="docker-registry.default.svc:5000" http.request.id=d49b28f3-1255-49c2-aade-4ea3dc215bbc http.request.method=POST http.request.remoteaddr="10.130.0.1:49706" http.request.uri="/v2/openrisknet-infra/home/blobs/uploads/" http.request.useragent="docker/1.12.6 go/go1.8.3 kernel/3.10.0-693.2.2.el7.x86_64 os/linux arch/amd64 UpstreamClient(go-dockerclient)" http.response.contenttype="application/json; charset=utf-8" http.response.duration=31.733223ms http.response.status=500 http.response.written=250 instance.id=072b4b30-f009-4141-9891-a6d37924bab9 openshift.auth.user="system:serviceaccount:openrisknet-infra:builder" openshift.logger=registry vars.name="openrisknet-infra/home"

Any suggestions for what to look at?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]