[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ansible with openstack cloud provider



Still stuck with this problem.

Has anyone successfully used Openstack V3 things like cinder volumes with Openshift?
Can you provide an example configuration?


On 25/11/17 18:21, Tim Dudgeon wrote:
On 24/11/2017 20:01, Joel Pearson wrote:
So I this is your own OpenStack installation?
No, I'm just a user.
How did you install it? OpenStack ansible? Packstack?
No idea.

Are your keystone endpoints https?
Yes. I my keystonerc file I have this:
export OS_AUTH_URL=https://x.y.z:5000/v3
(obviously not really x.y.z!)

What I'm most uncertain about is the tenant-id property. Seems that this is not needed is v3 (it was required in v2?), but the openshift ansible installer requires it to be set, but I'm not sure whether this is actually used, and if so, what it should be set to. I'm using the same value as the username, but that's just a guess.

On Sat, 25 Nov 2017 at 1:57 am, Tim Dudgeon <tdudgeon ml gmail com> wrote:

Wondered if anyone has any ideas on this.

I'm still stuck with it.


On 07/11/2017 11:29, Tim Dudgeon wrote:

I'm still struggling with this. Now that I specify a value for openshift_cloudprovider_openstack_tenant_id the openstack.conf file gets  created, but the master service fails to start because of:

Nov 07 11:17:20 test.openstacklocal origin-master[15001]: F1107 11:17:20.431262   15001 start_master.go:118] could not init cloud provider "openstack": Authentication failed

So something is still not right.

My openstack.conf that gets generated looks like this:

[Global]
auth-url = "" from $OS_AUTH_URL defined in keystonerc>
username = <value from $OS_USERNAME defined in keystonerc>
password = <value from $OS_PASSWORD defined in keystonerc>
domain-name = <value from $OS_USER_DOMAIN_NAME defined in keystonerc>
tenant-id = <same value as username>
region = <value from $OS_REGION_NAME defined in keystonerc>

The one thing I'm uncertain about is what to specify as the tenant-id as that is not defined in the v3 keystonerc.
I've used the value of the username but that may not be correct.

The value of password is the API password and works with the python openstack client.

Can anyone spot what is wrong?
What is Openshift tying to do when it tries to init the cloud provider and fails?




On 04/11/2017 11:51, Joel Pearson wrote:
I found it worked better if it uses the v3 keystone api. I tried the v2 keystone api, and it didn't work out of the box, I had to manually modify openstack.conf file.  It seems like something is not right, but I lost interest in the problem and just made the variables available that it wanted.

If you have issues with cinder, you might need to try my pull request too.


On Sat, Nov 4, 2017 at 9:21 PM Joel Pearson <japearson agiledigital com au> wrote:
Yes mine too, but if you want it to work you need to add it back. I grabbed those values from the v2 RC file.
On Sat, 4 Nov 2017 at 9:20 pm, Tim Dudgeon <tdudgeon ml gmail com> wrote:

Yes, I removed those because my setup file (Newton release) included this:

# unset v2.0 items in case set
unset OS_TENANT_ID
unset OS_TENANT_NAME

Is openshift expecting an earlier release?


On 04/11/2017 09:51, Joel Pearson wrote:
I added this to mine:

openshift_cloudprovider_openstack_tenant_name: "{{ lookup('env','OS_TENANT_NAME') }}"

On Sat, Nov 4, 2017 at 8:50 PM Joel Pearson <japearson agiledigital com au> wrote:
You're missing "(openshift_cloudprovider_openstack_tenant_id or openshift_cloudprovider_openstack_tenant_name )"

See: (openshift_cloudprovider_openstack_tenant_id is defined or openshift_cloudprovider_openstack_tenant_name is defined) in the file below


On Sat, Nov 4, 2017 at 8:41 PM Tim Dudgeon <tdudgeon ml gmail com> wrote:

On 03/11/2017 22:24, Joel Pearson wrote:

Are you actually filling in those values with anything?
Yes, all have values, I just didn't want to divulge them.

I setup OpenShift on OpenStack Kilo and I needed to make sure I was using the v3 rc file and I also had an issue with block storage the the OpenStack file which I submitted a patch for.

Are you using this OpenShift on OpenStack repo?

https://github.com/openshift/openshift-ansible-contrib/blob/master/playbooks/provisioning/openstack/README.md

No, the infrastructure is already provisioned. I'm, just using the openshift-ansible/playbooks/byo/config.yml playbook to provision openshift.

 
The error message suggests that potentially none of the variables have a value so the file isn’t being generated.
Well, they do have values and the file is not being generated. That's what I'm wanting to resolve.


On Sat, 4 Nov 2017 at 5:50 am, Tim Dudgeon <tdudgeon ml gmail com> wrote:
I'm trying to use the openstack provisioning stuff (cinder volumes etc.)
using the Ansible installer.
 From the origin docs key to this is to enable the openstack cloud
provider, which I try to do this this:

openshift_cloudprovider_kind=openstack
openshift_cloudprovider_openstack_auth_url=
openshift_cloudprovider_openstack_username=
openshift_cloudprovider_openstack_password=
openshift_cloudprovider_openstack_domain_name=
openshift_cloudprovider_openstack_region=
openshift_cloudprovider_openstack_lb_subnet_id=


But the Ansible installer fails (those being the only changes to the
inventory file that otherwise works fine).
Looking into the journal I find:

28188 plugins.go:115] Couldn't open cloud provider configuration
/etc/origin/cloudprovider/openstack.conf: &os.PathError{Op:"open",
Path:"/etc/origin/cloudprovider/openstack.conf", Err:0x2}

And indeed the /etc/origin/cloudprovider/ dir is empty.

So am I missing something important here?

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users
--
Kind Regards,

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: agiledigital.com.au

--
Kind Regards,

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: agiledigital.com.au
--
Kind Regards,

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: agiledigital.com.au

--
Kind Regards,

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: agiledigital.com.au
--
Kind Regards,

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: agiledigital.com.au


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]