[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cannot see Logs or use Terminal in latest



With a 500 I would expect to see something in the logs for the master. Anything there?

On Wed, Feb 22, 2017 at 2:02 PM, John Mazzitelli <mazz redhat com> wrote:
Same thing for both Logs and Terminal - getting a error code of 500 when the websocket tries to connect.

I have no idea why - this used to always work - until I started using the latest code.

----- Original Message -----
> Good call:
>
> (unknown) WebSocket connection to
> 'wss://192.168.1.15:8443/api/v1/namespaces/openshift-infra/pods/heapster-dln…xterm+%2Fbin%2Fsh&access_token=CpQs_rRQetCoiXwAamUgface2Op20B7bEO7p4mov_rw'
> failed: Error during WebSocket handshake: Unexpected response code: 500
>
> ----- Original Message -----
> > Can you open the network tab in the dev tools of your browser and look for
> > the websocket connections. I recommend using Chrome since it does a better
> > job of displaying websocket information.
> >
> > Any time both logs and terminal are not working, its usually a symptom of
> > websockets failing to open.
> >
> > On Wed, Feb 22, 2017 at 11:10 AM, John Mazzitelli < mazz redhat com >
> > wrote:
> >
> >
> > OK, I'm almost back to where I was when I had things working.
> >
> > I was using an older version and starting with "oc cluster up", I am now
> > using the latest builds and starting with "openshift start".
> >
> > But if I go to any pod's Logs tab in the UI console, I see this:
> >
> > "Logs are not available. The logs are no longer available or could not be
> > loaded."
> >
> > If I try to use the Terminal (in the UI terminal tab) I see this:
> >
> > "Could not connect to the container. Do you have sufficient privileges?"
> >
> > I am logged into the UI console as a user that is given cluster-admin role
> > -
> > so I assume I should be able to see everything.
> >
> > I used to be able to see these in the older versions I was using (when I
> > was
> > using oc cluster up). But now I can't.
> >
> > Am I missing a role or some permission?
> >
> > Versions:
> >
> > oc v1.5.0-alpha.3+2d20080-23
> > kubernetes v1.5.2+43a9be4
> > openshift v1.5.0-alpha.3+2d20080-23
> >
> > _______________________________________________
> > users mailing list
> > users lists openshift redhat com
> > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> >
> >
> > _______________________________________________
> > users mailing list
> > users lists openshift redhat com
> > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> >
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users
>

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]