[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cannot see Logs or use Terminal in latest



----- Original Message -----
> I normally do this:
> 
> $ openshift start --write-config openshift.local.config
> 
> $ sudo openshift start --master-config
> openshift.local.config/master/master-config.yaml --node-config
> openshift.local.config/<your node here>/node-config.yaml.
> 
> You can edit the config files as needed (although I rarely do). If you are
> just doing `openshift start --listen=`, it looks like the --hostname flag
> defaults to localhost.localdomain for naming the node. You might try
> changing that?
> 
> But maybe before you do, what do you get for:
> 
> sudo netstat -anp | grep 10250 | grep LISTEN


I get this:

$ sudo netstat -anp | grep 10250 | grep LISTEN
tcp  0  0  192.168.1.15:10250  0.0.0.0:*  LISTEN  17506/openshift     

"192.168.1.15" is my host IP and what I pass in to the --listen option of "openshift"


> 
> Andy
> 
> On Wed, Feb 22, 2017 at 4:00 PM, John Mazzitelli <mazz redhat com> wrote:
> 
> > Well, that's a good question. When I start OpenShift using the openshift
> > executable, I pass in --listen so I ensure it listens to my LAN IP - so I
> > do this:
> >
> > openshift start --listen=https://192.168.1.15:8443
> >
> > Is that bad? :)
> >
> > If you pass in a --listen option, is there something else I have to
> > specify?
> >
> > ----- Original Message -----
> > > 127.0.0.1:10250 is the OpenShift node's port. Is your OpenShift process
> > > listening on that port on the loopback interface?
> > >
> > > On Wed, Feb 22, 2017 at 2:17 PM, John Mazzitelli <mazz redhat com>
> > wrote:
> > >
> > > > The only thing that seems related (when I click on a Logs or Terminal
> > tab
> > > > in the UI -this is the only error that is logged):
> > > >
> > > > E0222 14:15:38.835307   31426 errors.go:63] apiserver received an error
> > > > that is not an unversioned.Status: Get https://localhost.localdomain:
> > > > 10250/containerLogs/default/hawkular-openshift-agent-
> > > > w7lsc/hawkular-openshift-agent?follow=true&limitBytes=
> > > > 10485760&tailLines=5000: dial tcp 127.0.0.1:10250: getsockopt:
> > connection
> > > > refused
> > > >
> > > >
> > > > ----- Original Message -----
> > > > > With a 500 I would expect to see something in the logs for the
> > master.
> > > > > Anything there?
> > > > >
> > > > > On Wed, Feb 22, 2017 at 2:02 PM, John Mazzitelli <mazz redhat com>
> > > > wrote:
> > > > >
> > > > > > Same thing for both Logs and Terminal - getting a error code of 500
> > > > when
> > > > > > the websocket tries to connect.
> > > > > >
> > > > > > I have no idea why - this used to always work - until I started
> > using
> > > > the
> > > > > > latest code.
> > > > > >
> > > > > > ----- Original Message -----
> > > > > > > Good call:
> > > > > > >
> > > > > > > (unknown) WebSocket connection to
> > > > > > > 'wss://192.168.1.15:8443/api/v1/namespaces/openshift-infra/
> > > > > > pods/heapster-dln…xterm+%2Fbin%2Fsh&access_token=CpQs_
> > > > > > rRQetCoiXwAamUgface2Op20B7bEO7p4mov_rw'
> > > > > > > failed: Error during WebSocket handshake: Unexpected response
> > code:
> > > > 500
> > > > > > >
> > > > > > > ----- Original Message -----
> > > > > > > > Can you open the network tab in the dev tools of your browser
> > and
> > > > look
> > > > > > for
> > > > > > > > the websocket connections. I recommend using Chrome since it
> > does a
> > > > > > better
> > > > > > > > job of displaying websocket information.
> > > > > > > >
> > > > > > > > Any time both logs and terminal are not working, its usually a
> > > > symptom
> > > > > > of
> > > > > > > > websockets failing to open.
> > > > > > > >
> > > > > > > > On Wed, Feb 22, 2017 at 11:10 AM, John Mazzitelli <
> > > > mazz redhat com >
> > > > > > > > wrote:
> > > > > > > >
> > > > > > > >
> > > > > > > > OK, I'm almost back to where I was when I had things working.
> > > > > > > >
> > > > > > > > I was using an older version and starting with "oc cluster
> > up", I
> > > > am
> > > > > > now
> > > > > > > > using the latest builds and starting with "openshift start".
> > > > > > > >
> > > > > > > > But if I go to any pod's Logs tab in the UI console, I see
> > this:
> > > > > > > >
> > > > > > > > "Logs are not available. The logs are no longer available or
> > could
> > > > not
> > > > > > be
> > > > > > > > loaded."
> > > > > > > >
> > > > > > > > If I try to use the Terminal (in the UI terminal tab) I see
> > this:
> > > > > > > >
> > > > > > > > "Could not connect to the container. Do you have sufficient
> > > > > > privileges?"
> > > > > > > >
> > > > > > > > I am logged into the UI console as a user that is given
> > > > cluster-admin
> > > > > > role
> > > > > > > > -
> > > > > > > > so I assume I should be able to see everything.
> > > > > > > >
> > > > > > > > I used to be able to see these in the older versions I was
> > using
> > > > (when
> > > > > > I
> > > > > > > > was
> > > > > > > > using oc cluster up). But now I can't.
> > > > > > > >
> > > > > > > > Am I missing a role or some permission?
> > > > > > > >
> > > > > > > > Versions:
> > > > > > > >
> > > > > > > > oc v1.5.0-alpha.3+2d20080-23
> > > > > > > > kubernetes v1.5.2+43a9be4
> > > > > > > > openshift v1.5.0-alpha.3+2d20080-23
> > > > > > > >
> > > > > > > > _______________________________________________
> > > > > > > > users mailing list
> > > > > > > > users lists openshift redhat com
> > > > > > > > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > > > > > > >
> > > > > > > >
> > > > > > > > _______________________________________________
> > > > > > > > users mailing list
> > > > > > > > users lists openshift redhat com
> > > > > > > > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > > > > > > >
> > > > > > >
> > > > > > > _______________________________________________
> > > > > > > users mailing list
> > > > > > > users lists openshift redhat com
> > > > > > > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > > > > > >
> > > > > >
> > > > > > _______________________________________________
> > > > > > users mailing list
> > > > > > users lists openshift redhat com
> > > > > > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > > > > >
> > > > >
> > > >
> > > > _______________________________________________
> > > > users mailing list
> > > > users lists openshift redhat com
> > > > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> > > >
> > >
> >
> > _______________________________________________
> > users mailing list
> > users lists openshift redhat com
> > http://lists.openshift.redhat.com/openshiftmm/listinfo/users
> >
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]