[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: DNS issue install OpenShift on OpenStack



Hello,

 

I see that your domain name is hosted by AWS. Maybe try to see if the domain is “public” or “private”, it seems private from what I can see (your entries do not resolve).
If it is private you should directly reference your DNS server in the “public_dns_nameservers” variable.

 

Good luck

 

De : <users-bounces lists openshift redhat com> au nom de Joel Pearson <japearson agiledigital com au>
Date : lundi 9 octobre
2017 à 14:54
À : "users lists openshift redhat com" <users lists openshift redhat com>
Objet : DNS issue install OpenShift on OpenStack

 

Hi, 

 

I'm trying to install openshift on openstack and I've been following https://github.com/openshift/openshift-ansible-contrib/tree/master/playbooks/provisioning/openstack I got past the openstack bit and now I'm installing openshift with “ansible-playbook openshift-ansible/playbooks/byo/config.yml” it got pretty far. 

 

Except it I got this error:

 

————

TASK [openshift_examples : Import Centos Image streams] *******************************************************************************************************************************

Monday 09 October 2017  12:30:17 +0000 (0:00:00.058)       0:05:10.675 ********

fatal: [master-0.openshift.staging.agiledigital.co]: FAILED! => {"changed": false, "cmd": ["oc", "create", "--config=/etc/origin/master/admin.kubeconfig", "-n", "openshift", "-f", "/usr/share/openshift/examples/image-streams/image-streams-centos7.json"], "delta": "0:00:00.309497", "end": "2017-10-09 12:30:18.114400", "failed": true, "failed_when_result": true, "rc": 1, "start": "2017-10-09 12:30:17.804903", "stderr": "Unable to connect to the server: dial tcp: lookup master-0.openshift.staging.agiledigital.co on 8.8.8.8:53: no such host", "stderr_lines": ["Unable to connect to the server: dial tcp: lookup master-0.openshift.staging.agiledigital.co on 8.8.8.8:53: no such host"], "stdout": "", "stdout_lines": []}

———-

 

I used the option of letting it install a DNS server in the openstack section, and I used this setting “public_dns_nameservers: [8.8.8.8,8.8.4.4]”, however it seems that it isn't using the dns server it installed, and hence internal DNS doesn't resolve.  

 

Is there a way to get the openstack-ansible playbooks to use the internal dns (which was created by “ansible-playbook openshift-ansible-contrib/playbooks/provisioning/openstack/provision.yaml”), which in my case is “10.2.100.5”? 

 

I figure I must have messed something up in the OpenStack provision section. But I don’t know what. 

 

Thanks,

 

Joel

--

Kind Regards,

 

Joel Pearson
Agile Digital | Senior Software Consultant

Love Your Software™ | ABN 98 106 361 273
p: 1300 858 277 | m: 0405 417 843 | w: 
agiledigital.com.au


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]