[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

No route to host when trying to connect to services



Hi guys,

I setup openshift origin cluster 3.6 and deployed 3 zookeeper instances as cluster.

I met error “no route to host" when trying to connect to one zookeeper via service.

The detailed information is as below,

zookeeper-1           172.30.64.134    <none>                          2181/TCP,2888/TCP,3888/TCP   10m
zookeeper-2           172.30.174.48    <none>                          2181/TCP,2888/TCP,3888/TCP   10m
zookeeper-3           172.30.223.77    <none>                          2181/TCP,2888/TCP,3888/TCP   10m
[root host-10-1-236-92 ~]# curl -kv zookeeper-1:3888
* Could not resolve host: zookeeper-1; Name or service not known
* Closing connection 0
curl: (6) Could not resolve host: zookeeper-1; Name or service not known
[root host-10-1-236-92 ~]# curl -kv zookeeper-1.aura.svc:3888
* About to connect() to zookeeper-1.aura.svc port 3888 (#0)
*   Trying 172.30.64.134...
* Connected to zookeeper-1.aura.svc (172.30.64.134) port 3888 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: zookeeper-1.aura.svc:3888
> Accept: */*
>
* Recv failure: Connection reset by peer
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer
[root host-10-1-236-92 ~]# curl -kv zookeeper-2.aura.svc:3888
* About to connect() to zookeeper-2.aura.svc port 3888 (#0)
*   Trying 172.30.174.48...
* No route to host
* Failed connect to zookeeper-2.aura.svc:3888; No route to host
* Closing connection 0
curl: (7) Failed connect to zookeeper-2.aura.svc:3888; No route to host
[root host-10-1-236-92 ~]# curl -kv zookeeper-3.aura.svc:3888
* About to connect() to zookeeper-3.aura.svc port 3888 (#0)
*   Trying 172.30.223.77...
* Connected to zookeeper-3.aura.svc (172.30.223.77) port 3888 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: zookeeper-3.aura.svc:3888
> Accept: */*
>
* Recv failure: Connection reset by peer
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer

The pods are running well.
How could I fix such problem?


Thanks,

Jared, (韦煜)
Software developer
Interested in open source software, big data, Linux


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]