[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Logging seems to be working, but no logs are collected



Hi All,

I've deployed logging using the ansible installer (v3.6.0) for a fairly simple openshift setup and everything appears to running:

NAME                                       READY     STATUS RESTARTS   AGE
logging-curator-1-gvh73                    1/1       Running 24         3d
logging-es-data-master-xz0e7a0c-1-deploy   0/1       Error 0          3d
logging-es-data-master-xz0e7a0c-4-deploy   0/1       Error 0          3d
logging-es-data-master-xz0e7a0c-5-deploy   0/1       Error 0          3d
logging-es-data-master-xz0e7a0c-7-t4xpf    1/1       Running 0          3d
logging-fluentd-4rm2w                      1/1       Running 0          3d
logging-fluentd-8h944                      1/1       Running 0          3d
logging-fluentd-n00bn                      1/1       Running 0          3d
logging-fluentd-vt8hh                      1/1       Running 0          3d
logging-kibana-1-g7l4z                     2/2       Running 0          3d

(the failed pods were related to getting elasticsearch running, but that was resolved).

The problem is that I don't see any logs in Kibana. When I look in the fluentd pod logs I see lots of stuff like this:

2017-10-31 13:53:15 +0000 [warn]: no patterns matched tag="journal.system"
2017-10-31 13:58:02 +0000 [warn]: no patterns matched tag="kubernetes.journal.container"
2017-10-31 14:02:18 +0000 [warn]: no patterns matched tag="journal.system"
2017-10-31 14:07:15 +0000 [warn]: no patterns matched tag="journal.system"
2017-10-31 14:11:20 +0000 [warn]: no patterns matched tag="journal.system"
2017-10-31 14:15:16 +0000 [warn]: no patterns matched tag="journal.system"
2017-10-31 14:19:58 +0000 [warn]: no patterns matched tag="journal.system"

Is this the cause, and if so what is wrong?
If not how to debug this?

Tim





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]