[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: 500 Error when pushing to internal registry





On Mon, Sep 18, 2017 at 12:47 PM, Graigry Henrie <gwhenrie chem byu edu> wrote:
We recently installed openshift origin using an ansible playbook.  We had used the same one before without issue, except that now when projects attempt to push to the internal registry, it results in a 500 error.  

Attached is the log from attempting to build the Django Example project.  The build itself proceeds perfectly, but fails with a "500 Internal Server Error" when attempting to push to the internal registry.  Checking the logs of the registry itself only shows health checks, indicating that container has come up properly.

What makes it more confusing is that we have installed with this same file multiple times and sometimes it works and sometime it doesn't.  We believe that it is a permissions issue.  We have checked and rechecked our ansible hosts file, but we cannot see what the problem is.  I have included it as well.

can you try manually pushing to the registry using the service account's token?  (ie docker login to the registry w/ the token and then tag an image+push to it).

There is a known issue that the registry returns 500 errors when it should return 403s, so your theory that it is a permission issue is plausible but it is strange that some of your clusters work.  When it is not working, it sounds like it is broken for all projects in the cluster, not just some or fails randomly?

Adding our registry gurus to CC.

 

We are happy to include any additional information as needed.

Thank you,

Graigry Henrie

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users




--
Ben Parees | OpenShift


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]