[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: How to avoid upgrading to 3.10?



Thanks for the replies! Changing the yum repo from centos-release-openshift-origin to centos-release-openshift-origin39 addressed my issue. I can now once again deploy OpenShift 3.9!

On Wed, Aug 15, 2018 at 8:11 AM Scott Dodson <sdodson redhat com> wrote:
The packages that the installer uses come from the CentOS PaaS SIG. By default they point at a repo that includes all releases unless we have a repo specific for the release you're using defined in openshift-ansible.

@DanyC97 added a 3.9 repo to the 3.9 branch a day or two ago, you can use this to replace your existing yum repo file and it will continue to track 3.9.
https://github.com/openshift/openshift-ansible/pull/9549

On Wed, Aug 15, 2018 at 4:21 AM David Conde <david donedeal ie> wrote:
I also have to remove openshift_pkg_version and set openshift_release=3.9.0 Hope this helps


On Wed, Aug 15, 2018 at 9:10 AM David Conde <david donedeal ie> wrote:
This caught me out yesterday also, a fix is on the 3.9 branch now so updating from there should help. If using AWS you will have to rebuild your AMI also as far as I know so that the new yum repo files are picked up.

On Tue, Aug 14, 2018 at 9:12 PM Peter Heitman <peter heitman us> wrote:
I use ansible to deploy OpenShift. All of my current deployments are 3.9 and I'd like to stay on 3.9 until we can do enough testing on 3.10 to be comfortable upgrading.

Can someone point me to any documentation on how to avoid the forced upgrade to 3.10 when I deploy a new instance of OpenShift? I currently checkout release-3.9 of the ansible scripts:

cd openshift-ansible
git checkout release-3.9

My inventory has the variables

openshift_release=v3.9
openshift_pkg_version=-3.9.0

and yet I get the error below. How do I stay on 3.9?

Failure summary:


  1. Hosts:    ph-dev-pshtest-master.pdx.hcl.com, ph-dev-pshtest-minion1.pdx.hcl.com, ph-dev-pshtest-minion2.pdx.hcl.com, ph-dev-pshtest-minion3.pdx.hcl.com
     Play:     OpenShift Health Checks
     Task:     Run health checks (install) - EL
     Message:  One or more checks failed
     Details:  check "package_version":
               Some required package(s) are available at a version
               that is higher than requested
                 origin-3.10.0
                 origin-node-3.10.0
                 origin-master-3.10.0
               This will prevent installing the version you requested.
               Please check your enabled repositories or adjust openshift_release.
_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users
_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]