[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: origin3.9 deployments



Alan, Todd,

i think i kind of clarified few things in my response [1].

In the future will be good if for same issue we stick to same email thread to not lose any info - bouncing between threads is getting a bit unmanageable in my opinion.

Dani

[1]https://github.com/openshift/openshift-ansible/issues/9675#issuecomment-414488090


On Mon, Aug 20, 2018 at 4:53 PM, Alan Christie <achristie informaticsmatters com> wrote:
Thanks Todd.

It does appear to be a part of the “openshift-ansible/playbooks/prerequisites.yml” playbook that is documented. It’s the one installing the repos. Everything was fine a week ago but broke for me last week.

Alan Christie
achristie informaticsmatters com



> On 20 Aug 2018, at 16:50, Walters, Todd <Todd_Walters unigroup com> wrote:
>
> Ok, good luck. We set our own repo versions. Never had luck and didn’t realize the playbooks installed repos. Thought that was a prereq. At least in enterprise it was.  Hope it works out for you.
>
> On 8/20/18, 10:47 AM, "Alan Christie" <achristie informaticsmatters com> wrote:
>
>    Thanks,
>
>    I’ve tried all sorts of things now and need a rest - I’ve been trying to understand this behaviour for the lat 7 hours and the working day’s approaching its end for me!
>
>    In the meantime I’m raising this an an issue as requested as I shouldn’t need to tinker with repos that are being installed by the OpenShift playbooks. I use tagged releases and am using "openshift-ansible-3.9.40-1”. The rest of the details will go in the issue.
>
>    In the meantime I’m just going to set “package_version” in the "openshift_disable_check” list in the inventory.
>
>    Alan Christie
>    achristie informaticsmatters com
>
>
>
>> On 20 Aug 2018, at 16:33, Walters, Todd <Todd_Walters unigroup com> wrote:
>>
>> I believe have the proper repos enabled is part of the node prerequisites.   So we get around this by running prereq playbook and disabling the origin release for latest (repo with no release number on end) and enabling 3.9 only
>>
>> - name: Install Specific Version of Openshift Origin
>> yum:
>>   name: centos-release-openshift-origin
>>   state: absent
>>
>> - name: Install Specific Version of Openshift Origin
>> yum:
>>   name: centos-release-openshift-origin39
>>   state: present
>>
>> Also, only git branch that’s supposed to work is release-3.9, which is what we always pull for playbooks.
>>
>> Thanks,
>>
>> Todd
>>
>> Today's Topics:
>>
>>      1. Re: Ansible/Origin 3.9 deployment now fails because
>>         "package(s) areavailable at a version that is higher than
>>         requested" (Alan Christie)
>>      2. Re: Ansible/Origin 3.9 deployment now fails because
>>         "package(s) areavailable at a version that is higher than
>>         requested" (Alan Christie)
>>
>>
>>   ----------------------------------------------------------------------
>>
>>   Message: 1
>>   Date: Mon, 20 Aug 2018 16:11:50 +0100
>>   From: Alan Christie <achristie informaticsmatters com>
>>   To: Peter Heitman <peter heitman us>
>>   Cc: users <users lists openshift redhat com>
>>   Subject: Re: Ansible/Origin 3.9 deployment now fails because
>>   "package(s) areavailable at a version that is higher than requested"
>>   Message-ID:
>>   <F63815B5-8756-4000-8A62-054CCD59F011@informaticsmatters.com>
>>   Content-Type: text/plain; charset="utf-8"
>>
>>   I?m doing pretty-much the same thing. Prior to ?prerequisites? I run the following play:
>>
>>   - hosts: nodes
>>     become: yes
>>
>>     tasks:
>>
>>     - name: Install origin39 repo
>>       yum:
>>         name: centos-release-openshift-origin39
>>         state: present
>>
>>   The 3.9 repo appears in /etc/yum.repos.d/ but, after the prerequisites, so does "CentOS-OpenShift-Origin.repo? and the main ?deploy_cluster.yml? fails again. The only way through this for me to add ?package_version? to ?openshift_disable_check?.
>>
>>   Alan Christie
>>   achristie informaticsmatters com
>>
>>
>>
>>
>> ########################################################################
>> The information contained in this message, and any attachments thereto,
>> is intended solely for the use of the addressee(s) and may contain
>> confidential and/or privileged material. Any review, retransmission,
>> dissemination, copying, or other use of the transmitted information is
>> prohibited. If you received this in error, please contact the sender
>> and delete the material from any computer. UNIGROUP.COM
>> ########################################################################
>>
>
>
>
>
> ########################################################################
> The information contained in this message, and any attachments thereto,
> is intended solely for the use of the addressee(s) and may contain
> confidential and/or privileged material. Any review, retransmission,
> dissemination, copying, or other use of the transmitted information is
> prohibited. If you received this in error, please contact the sender
> and delete the material from any computer. UNIGROUP.COM
> ########################################################################
>


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]