[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Upgrade the HAProxy inside the Openshift (to match the OSCP version)



Hi.

I have created one in the past and now a new one with 1.8.15

https://hub.docker.com/r/me2digital/openshift-ocp-router-hap18

It's untested as I have not running a ocp/okd for now but it should work.

###

|docker run --rm --entrypoint /usr/local/sbin/haproxy
me2digital/openshift-ocp-router-hap18 -vv HA-Proxy version 1.8.15 2018/12/13
Copyright 2000-2018 Willy Tarreau <willy haproxy org> Build options : TARGET =
linux2628 CPU = generic CC = gcc CFLAGS = -O2 -g -fno-strict-aliasing
-Wdeclaration-after-statement -fwrapv -Wno-unused-label OPTIONS =
USE_LINUX_SPLICE=1 USE_GETADDRINFO=1 USE_ZLIB=1 USE_REGPARM=1 USE_OPENSSL=1
USE_LUA=1 USE_PCRE=1 USE_PCRE_JIT=1 USE_TFO=1 Default settings : maxconn = 2000,
bufsize = 16384, maxrewrite = 1024, maxpollevents = 200 Built with OpenSSL
version : OpenSSL 1.0.2k-fips 26 Jan 2017 Running on OpenSSL version : OpenSSL
1.0.2k-fips 26 Jan 2017 OpenSSL library supports TLS extensions : yes OpenSSL
library supports SNI : yes OpenSSL library supports : SSLv3 TLSv1.0 TLSv1.1
TLSv1.2 Built with Lua version : Lua 5.3.4 Built with transparent proxy support
using: IP_TRANSPARENT IPV6_TRANSPARENT IP_FREEBIND Encrypted password support
via crypt(3): yes Built with multi-threading support. Built with PCRE version :
8.32 2012-11-30 Running on PCRE version : 8.32 2012-11-30 PCRE library supports
JIT : yes Built with zlib version : 1.2.7 Running on zlib version : 1.2.7
Compression algorithms supported : identity("identity"), deflate("deflate"),
raw-deflate("deflate"), gzip("gzip") Built with network namespace support.
Available polling systems : epoll : pref=300, test result OK poll : pref=200,
test result OK select : pref=150, test result OK Total: 3 (3 usable), will use
epoll. Available filters : [SPOE] spoe [COMP] compression [TRACE] trace|

###

Best regards
Aleks

Am 15.12.2018 um 15:11 schrieb Jan-Otto Kröpke:
> Hi,
>
> it is possible to upgrade the HAProxy version from 1.8.1 to 1.8.14 to match
> the version of haproxy inside OSCP?
>
> HAProxy 1.8.1 has a lot of issues with h2 (there are 44 bugfixes related to h2
> since 1.8.1; https://www.haproxy.org/download/1.8/src/CHANGELOG). Also the
> thread implementation seems to be buggy in 1.8.1.
>
> Can someone provide a newer haproxy-router image with the haproxy version of OSCP?
>
> The SRPMs are available
> here: http://ftp.redhat.com/redhat/linux/enterprise/7Server/en/RHOSE/SRPMS/
>
> It would be great if OKD and OSCP using the same version.
>
> Best,
> Jan
>
> _______________________________________________
> users mailing list
> users lists openshift redhat com
> http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]