Looks like this problem has fixed itself over the last couple of
weeks (I just updated openshift-ansible on the release-3.7 branch)
That package dependency error is no longer happening.
It now seems possible to deploy a minimal 3.7 distribution using
the Ansible installer.
I have no idea what the source of the problem was or what has
I tried disabling the package checks but this just pushes the
failure down the line:
1. Hosts: host-10-0-0-10, host-10-0-0-12, host-10-0-0-13,
Play: Configure nodes
Task: Install sdn-ovs package
Message: Error: Package:
Requires: openvswitch >= 2.6.1
Something seems broken with the package dependencies?
This happens when trying to install v3.7 using
openshift-ansible from branch release-3.7.
On 21/12/17 16:48, Tim Dudgeon wrote:
Yes, but is this error a result of broken dependencies in the
There's no mention of needing to instal openvswitch as part of
the pre-requisites mentioned here:
On 20/12/17 20:27, Joel Pearson
in the paas repo http://mirror.centos.org/centos/7/paas/x86_64/openshift-origin/
starting hitting this error when using the ansible
(installing v3.70 from openshift-ansible on branch
1. Hosts: host-10-0-0-10, host-10-0-0-13,
Play: OpenShift Health Checks
Task: Run health checks (install) - EL
Message: One or more checks failed
Details: check "package_availability":
Could not perform a yum update.
Errors from dependency resolution:
openvswitch >= 2.6.1
You should resolve these issues before
You may need to remove or downgrade
enable/disable yum repositories.
Not all of the required packages are
available at their
openvswitch:['2.6', '2.7', '2.8']
Please check your subscriptions and
This was not happening before. Where does openvswitch come
find it in the standard rpm repos.
users mailing list
users lists openshift redhat com