[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Regarding Logging



On 11/19/18 8:32 AM, Kasturi Narra wrote:
Hello Jeff,
   yes , i do have it. Here is the output i have got.

dhcp46-68.lab.eng.blr.redhat.com <http://dhcp46-68.lab.eng.blr.redhat.com>    Ready     <none>    6d        v1.9.1+a0ce1bc657 beta.kubernetes.io/arch=amd64,beta.kubernetes.io/os=linux,kubernetes.io/hostname=dhcp46-68.lab.eng.blr.redhat.com,logging-infra-fluentd=true,region=infra,registry=enabled,role=node,router=enabled <http://beta.kubernetes.io/arch=amd64,beta.kubernetes.io/os=linux,kubernetes.io/hostname=dhcp46-68.lab.eng.blr.redhat.com,logging-infra-fluentd=true,region=infra,registry=enabled,role=node,router=enabled>


oc get daemonset

oc describe daemonset logging-fluentd


Thanks
kasturi

On Mon, Nov 19, 2018 at 7:16 PM Jeff Cantrill <jcantril redhat com <mailto:jcantril redhat com>> wrote:

    It doesn't appear you have any fluentd pods which are responsible for collecting logs from the other pods.  Are your nodes labeled with 'logging-infra-fluend=true'

    On Mon, Nov 19, 2018 at 7:28 AM Kasturi Narra <knarra redhat com <mailto:knarra redhat com>> wrote:

        Hello Everyone,

           I have a setup where i am trying to install logging using ocp3.9+ cns3.11 . I see that logging pods are up and running but when i access the webconsole i get an error  present at
        [1]  and i tried the solution provided at [2] but having no luck. Can some one of you please help me on resolving this issue ?

        [root dhcp46-170 ~]# oc version
        oc v3.9.43
        kubernetes v1.9.1+a0ce1bc657
        features: Basic-Auth GSSAPI Kerberos SPNEGO

        Server https://dhcp46-170.lab.eng.blr.redhat.com:8443
        openshift v3.9.43
        kubernetes v1.9.1+a0ce1bc657

        [root dhcp46-170 ~]# oc get pods
        NAME  READY     STATUS    RESTARTS   AGE
        logging-curator-1-bgjbj 1/1       Running   0          2h
        logging-es-data-master-5gjnm57x-2-5vjq6 2/2       Running   0          2h
        logging-kibana-1-872dn  2/2       Running   0          2h

        [1] Discover: [exception] The index returned an empty result. You can use the Time Picker to change the time filter or select a higher time interval
        [2] https://access.redhat.com/solutions/3352681

        Thanks
        kasturi
        _______________________________________________
        users mailing list
        users lists openshift redhat com <mailto:users lists openshift redhat com>
        http://lists.openshift.redhat.com/openshiftmm/listinfo/users



-- --
    Jeff Cantrill
    Senior Software Engineer, Red Hat Engineering
    OpenShift Logging
    Red Hat, Inc.
    *Office*: 703-748-4420 | 866-546-8970 ext. 8162420
    jcantril redhat com <mailto:jcantril redhat com>
    http://www.redhat.com


_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]