[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Can't upgrade okd from 3.10 --> 3.11, odd "failed to backup etcd" error



figured out the issue.  my ansible box was running 2.7.  Downgraded to 2.6 and was able to run the install

On Sun, Nov 25, 2018 at 2:37 PM Marc Boorshtein <mboorshtein gmail com> wrote:
I'm trying to ugprade okd from 3.10 to 3.11.  When I run the control plane upgrade I get the following error:

TASK [fail] ***********************************************************************************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Upgrade cannot continue. The following hosts did not complete etcd backup: 10.0.4.57"}
to retry, use: --limit @/root/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_11/upgrade_control_plane.retry

PLAY RECAP ************************************************************************************************************
10.X.X.X                 : ok=21   changed=1    unreachable=0    failed=0   
10.X.X.X               : ok=22   changed=1    unreachable=0    failed=0   
10.X.X.X                  : ok=165  changed=16   unreachable=0    failed=0   
Zone=us-east-1a            : ok=1    changed=0    unreachable=0    failed=0   
localhost                  : ok=27   changed=0    unreachable=0    failed=1   

Here's the odd thing, I don't have localhost anywhere in my inventory.  I run a seperate box with ansible on it just for running playbooks.  Googling took me to https://github.com/openshift/openshift-ansible/issues/4475 but i'm not using --connection localhost

Thanks

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]