[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Migration from 3.10 to 3.11



* Hyde Stevenson <hyde nodistrict com> [2019-04-17 16:44:12 +0200] wrote :

[...]


> Don't have that error anymore with this version of ansible but got that
> one :
>
>      Play:     Install packages necessary for installer
>      Task:     Install ntp package
>      Message:  The conditional check 'chrony_installed.rc != 0' failed. The error was: error while evaluating conditional (chrony_installed.rc != 0): 'dict object' has no attribute 'rc'
>
>                The error appears to have been in 'openshift-ansible/playbooks/init/base_packages.yml': line 16, column 5, but may
>                be elsewhere in the file depending on the exact syntax problem.
>
>                The offending line appears to be:
>
>                  # atomic here.
>                  - name: Install ntp package

Hello,

Looks like the dry-run actually doesn't work ...
We had the green light to upgrade to 3.11 and when I launch the
ansible-playbook I dont have anymore the issue above.

But, because there is always a but with that installation, the process
keeps running and halting on this task :

TASK [openshift_excluder : Get available excluder version]

When I do a strace on the pid I get a lot of this :

select(0, NULL, NULL, NULL, {tv_sec=0, tv_usec=1000}) = 0 (Timeout)
select(0, NULL, NULL, NULL, {tv_sec=0, tv_usec=1000}) = 0 (Timeout)
select(0, NULL, NULL, NULL, {tv_sec=0, tv_usec=1000}) = 0 (Timeout)

without any other information :(

Any idea what could be the issue ?

Kind regards,

--
Hyde Stevenson


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]