[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

route not working and I'm at my wits end



Hi,

    I'm able to use port-forwarding to verify that my service is functioning properly.

curl -v -u abcd:abcd@ -H "Accept: application/json" --cookie-jar cookie-jar --cookie cookie-jar http://localhost:9080/session-song-demo/sing/song?seen=47
* About to connect() to localhost port 9080 (#0)
*   Trying ::1...
* Connected to localhost (::1) port 9080 (#0)
* Server auth using Basic with user 'abcd'
> GET /session-song-demo/sing/song?seen=47 HTTP/1.1
> Authorization: Basic YWJjZDphYmNkQA==
> User-Agent: curl/7.29.0
> Host: localhost:9080
> Cookie: JSESSIONID=0001cbGiUXt_VtxdTW9Xa8c1W_s:c5f5e43e-3adb-4a42-bf12-e67265711b02; LtpaToken2=IL+wSFBcnsOi9+fpHR8PgzJak7eRwRAPoSdHPRZoSjJuSMA11/DKqYA8Lld79i5LB6j51ihR5OqXKifGQAxC3t70aQxRWH2y2xqS7L+lairHAAu86QARt2OzYDX39FA/N8IPwcCJOwlm0Z89ZClks7PEQmy0csAV+CTo4uHIiZu9CY1kOfp2oH9Q9H3KkTZQGLHNKmwBF41BXmWtSwc6AvNbbDL6kuFjAi+Ahui8QjBAPKAIMb7Z4PKMdhwkzMKUObgS6iBAy7tHeQMknrmolzRpmz00mpfjVQvkzKNzvL9VZ74a27MC0vRM5N185nCr
> Accept: application/json
>
< HTTP/1.1 200 OK
< X-Powered-By: Servlet/4.0
< Content-Type: application/json
< Date: Fri, 13 Dec 2019 07:39:35 GMT
< Content-Language: en-US
< Content-Length: 33
<
* Connection #0 to host localhost left intact
{"count":43,"name":"nightingale"}

    However, when trying to get at this service through a route, it gives me the catch-all router error page:
image.png
    Here is the route definition:

zaphod oc6010654212 session-song-demo]$ oc describe route song-demo
Name: song-demo
Namespace: session-persistence
Created: 43 hours ago
Labels: app=song-demo
app.kubernetes.io/component=song-demo
app.kubernetes.io/instance=song-demo
Annotations: <none>
Requested Host: song-demo.apps-crc.testing
 exposed on router default (host apps-crc.testing) 43 hours ago
Path: <none>
TLS Termination: <none>
Insecure Policy: <none>
Endpoint Port: 9080-tcp

Service: song-demo
Weight: 100 (100%)
Endpoints: 10.128.1.211:9443, 10.128.1.211:9080
[zaphod oc6010654212 session-song-demo]$ 

    I've been through numerous variations without much success, and the logs of the router in openshift-ingress aren't showing anything significant. Is there a way to troubleshoot this and find out whats going wrong?

Regards,
Marvin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]