[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: HPA not getting metrics



Hi,

just to make this complete: I gave up on adding metrics to an existing
OKD installation. Neither openshift-metrics/config.yml nor
metrics-server/config.yml nor both lead to working autoscaling.

Instead I reinstalled the cluster with

openshift_metrics_install_metrics=true
openshift_metrics_hawkular_hostname=\
	hawkular-metrics.{{openshift_master_default_subdomain}}

Regards,
Robert


On 02.07.2019 18:38, Robert Dahlem wrote:

Dan,

On 01.07.2019 19:30, Punga Dan wrote:

First thing I'd note is that we should use the OKD documentation. I
guess that in most parts this is quite similar with the OCP version, but
just to be on the safe side.

Yes, you are right.

With the command documented on the Pod Autoscaling page. Both the OKD
and OCP doc(which you've linked) states the same thing:
ansible-playbook \
/usr/share/ansible/openshift-ansible/playbooks/*metrics-server*/config.yml
\
*-e openshift_metrics_server_install=true*

Thank you for pointing this out. I used openshift-metrics/config.yml and
openshift_metrics_install_metrics=true before, which is clearly wrong
according to the Pod Autoscaling page.

I uninstalled that and ran the playbook as you suggested.

Now the Web console tells me "Metrics might not be configured by your
cluster administrator. Metrics are required for autoscaling."

This is probably not completely right, because:

# oc get hpa
NAME   REFERENCE                 TARGETS  MINPODS MAXPODS REPLICAS AGE
$MYAPP DeploymentConfig/$MYAPP   0%/75%   1       5       1         4m

The "0%" tells me that somewhere the HPA gets actual metrics.

I will investigate further tomorrow.

Kind regards,
Robert

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]