[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: master default subdomain keeps redirecting to master FQDN



To you too, have fun ;)

On Sat, Jun 1, 2019, 8:33 PM Ricardo Mendes <maverickws outlook pt> wrote:
Awe man, amazing, thanks!

Totally had the wrong idea. Have a great weekend!

Ricardo Mendes

From: Samuel Martín Moro <faust64 gmail com>
Sent: Saturday, June 1, 2019 19:12
To: Ricardo Mendes
Cc: OpenShift Users List
Subject: Re: master default subdomain keeps redirecting to master FQDN
 
Definitely
Your infra node hosts some haproxy container (deploymentconfig router in the default namespace).
That's the one that would route external requests to your applications. The master node would only expose your cluster API service.

Regards

On Sat, Jun 1, 2019, 8:07 PM Ricardo Mendes <maverickws outlook pt> wrote:
Hi Samuel,

Thanks for the quick reply.

*.apps is pointing to master, not infra. 

```
[OSEv3:children]
masters
etcd
nodes

[masters]
master.domain.com openshift_schedulable=True

[etcd]
master.domain.com openshift_schedulable=True

[nodes]
master.domain.com openshift_node_group_name='node-config-master' openshift_schedulable=True
infra.domain.com openshift_node_group_name='node-config-infra' openshift_schedulable=True
node1.domain.com openshift_node_group_name='node-config-compute' openshift_schedulable=True
```

Should I point to infra instead?

Kind regards,
Ricardo Mendes



From: Samuel Martín Moro <faust64 gmail com>
Sent: Saturday, June 1, 2019 19:03
To: Ricardo Mendes
Cc: OpenShift Users List
Subject: Re: master default subdomain keeps redirecting to master FQDN
 
Hi

That sounds like an issue with your DNS records
Could you confirm *.apps points to the infra node(s)?

Regards.


On Sat, Jun 1, 2019, 8:00 PM Ricardo Mendes <maverickws outlook pt> wrote:
Hello all,

I have a 3 server setup with 1 master 1 infra 1 node.

I have finished the setup with deploy_cluster.yml all goes well.
DNS wise, my DNS server is pointing *.apps to the master ip

Happens that each time I access any of the custom subdomain url, I am directed to master.domain.com FQDN, and I can't access any of the subcontainers.

How can I solve this? 
Thanks

Ricardo Mendes

_______________________________________________
users mailing list
users lists openshift redhat com
http://lists.openshift.redhat.com/openshiftmm/listinfo/users

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]