[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

OpenShift 3.11 Upgrade pre-checks fail



Greetings, I'm attempting to perform an in-place upgrade of a 9 node OKD 3.11 cluster and have run the docker version issue below:

$ ansible-playbook -i inventory.ini openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_11/upgrade.yml 


TASK [container_runtime : Required docker version not available (non-atomic)] ***************************************************************************************************************************************************************
fatal: [lmaster1]: FAILED! => {"changed": false, "msg": "This playbook requires access to Docker 1.13 or later"}
fatal: [lmaster2]: FAILED! => {"changed": false, "msg": "This playbook requires access to Docker 1.13 or later"}
fatal: [master3]: FAILED! => {"changed": false, "msg": "This playbook requires access to Docker 1.13 or later"}
        to retry, use: --limit @/home/origin/openshift-ansible/playbooks/byo/openshift-cluster/upgrades/v3_11/upgrade.retry

PLAY RECAP **********************************************************************************************************************************************************************************************************************************
master1      : ok=158  changed=10   unreachable=0    failed=1   
master2     : ok=132  changed=10   unreachable=0    failed=1   
master3     : ok=132  changed=10   unreachable=0    failed=1   
localhost                  : ok=28   changed=0    unreachable=0    failed=0   


INSTALLER STATUS ****************************************************************************************************************************************************************************************************************************
Initialization  : Complete (0:02:34)

Failure summary:

  1. Hosts:    master1,master2,master3
     Play:     Verify docker upgrade targets
     Task:     Required docker version not available (non-atomic)
     Message:  This playbook requires access to Docker 1.13 or later

oc version
oc v3.11.0+62803d0-1
kubernetes v1.11.0+d4cacc0
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://console-ext.okd.local.domain:443
openshift v3.11.0+d0c29df-98
kubernetes v1.11.0+d4cacc0

I'm using the same inventory file I used to build the cluster initially and docker 1.13 is installed.

rpm -qa |grep docker |sort
cockpit-docker-176-2.el7.centos.x86_64
docker-1.13.1-75.git8633870.el7.centos.x86_64
docker-client-1.13.1-75.git8633870.el7.centos.x86_64
docker-common-1.13.1-75.git8633870.el7.centos.x86_64
origin-docker-excluder-3.11.0-1.el7.git.0.62803d0.noarch
python-docker-py-1.10.6-4.el7.noarch
python-docker-pycreds-1.10.6-4.el7.noarch

I'm not really sure what to check for troubleshooting since docker 1.13 is already installed on all of the nodes.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]