[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Logging breaking metrics in OCP 3.3?



Hi all,

Facing an odd situation here and was hoping for some feedback.

I'm trying to stand up two OCP 3.3 HA environments (3/3/4) with logging and metrics.  I'm installing metrics from the Ansible playbooks like so:

# metrics
openshift_hosted_metrics_deploy=true
openshift_hosted_metrics_storage_kind=nfs
openshift_hosted_metrics_storage_access_modes=['ReadWriteOnce']
openshift_hosted_metrics_storage_host=fc-cifs03.corp.follett.com
openshift_hosted_metrics_storage_nfs_directory=/OCPQA_INFRA01
openshift_hosted_metrics_storage_volume_name=metrics
openshift_hosted_metrics_storage_volume_size=75Gi
openshift_hosted_metrics_public_url=https://hawkular-metrics.qa.ocp.domain.com/hawkular/metrics

This results in a successful metrics installation.  Metrics are displayed for each pod on the overview page, etc.

Next, I want to go back and add logging, so I comment out the metrics stuff from the 'hosts' file, and add the logging config:

# logging
openshift_hosted_logging_deploy=true
openshift_hosted_logging_storage_kind=nfs
openshift_hosted_logging_storage_access_modes=['ReadWriteOnce']
openshift_hosted_logging_storage_host=<nfsserver>
openshift_hosted_logging_storage_nfs_directory=<nfsexport>
openshift_hosted_logging_storage_volume_name=logging
openshift_hosted_logging_storage_volume_size=150Gi

After a successful playbook run, the logging pods come up fine (not sure if they are totally operational), but something is causing my metrics data to vanish.  Metrics stats are no longer visibly on the pod overview page or in the pod details page.  I don't see any errors on any of the logging and/or metrics pods.  I have been able to consistently reproduce this in multiple environments.

Any ideas on how to troubleshoot this?

Thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]